<!DOCTYPE HTML>
<html lang="en-US">
	<head><meta charset="UTF-8"><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
		
		<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
					<link rel="pingback" href="https://www.debugpoint.com/xmlrpc.php">
				<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
	<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		(function( $ ) {

			var themeModeStylesheetURL = 'https://www.debugpoint.com/wp-content/themes/boombox/css/night-mode.min.css';
			var getCookie = function( cname ) {
				var name = cname + "=";
				var decodedCookie = decodeURIComponent( document.cookie );
				var ca = decodedCookie.split( ';' );
				for ( var i = 0; i < ca.length; i++ ) {
					var c = ca[i];
					while ( c.charAt( 0 ) == ' ' ) {
						c = c.substring( 1 );
					}
					if ( c.indexOf( name ) == 0 ) {
						return c.substring( name.length, c.length );
					}
				}
				return "";
			};
			var setCookie = function( cname, cvalue, exdays ) {
				var d = new Date();
				d.setTime( d.getTime() + (exdays * 24 * 60 * 60 * 1000) );
				var expires = "expires=" + d.toUTCString();
				document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
			};
			var delete_cookie = function( cname ) {
				setCookie( cname, null, 0 );
			};
			var appendThemeModeLink = function() {
				var link = document.createElement( 'link' );
				var targetNode = document.getElementById( 'boombox-primary-style-inline-css' );
				link.rel = 'stylesheet';
				link.id = 'boombox-theme-mode-css';
				link.href = themeModeStylesheetURL;
				link.media = 'all';

				targetNode.parentNode.insertBefore( link, targetNode.nextSibling );
			};

			document.addEventListener( 'DOMContentLoaded', function() {
				var switchers = document.querySelectorAll( '.bb-mode-switcher .bb-mode-toggle' );

				for ( var i = 0; i < switchers.length; i++ ) {
					switchers[i].addEventListener( 'click', function(e) {
					    e.preventDefault();
						var stylesheet = document.getElementById( 'boombox-theme-mode-css' );
						if ( !!getCookie( 'boombox-theme-mode' ) ) {
							if ( stylesheet ) {
								stylesheet.setAttribute( 'disabled', 'disabled' );
							}
                            document.body.classList.remove("boombox-mode-on");
							delete_cookie( 'boombox-theme-mode' );
						} else {
							if ( stylesheet ) {
								stylesheet.removeAttribute( 'disabled' );
							} else {
								appendThemeModeLink();
							}
                            document.body.classList.add("boombox-mode-on");
							setCookie( 'boombox-theme-mode', 1, 365 );
						}
					} );
				}

                if ( !!getCookie( 'boombox-theme-mode' ) ) {
                    document.body.classList.add("boombox-mode-on");
                }
			} );

			if ( !!getCookie( 'boombox-theme-mode' ) ) {

				var appendInterval = setInterval( function() {
					if ( document.getElementById( 'boombox-primary-style-inline-css' ) ) {
						clearInterval( appendInterval );
						appendThemeModeLink();
					}
				}, 25 );
			}

		})();
	</script>
	<!-- This site is optimized with the Yoast SEO plugin v19.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>How to Install FFmpeg in Ubuntu and Other Linux</title>
	<meta name="description" content="A tutorial on how you can install the FFmpeg package in Ubuntu and other Linux distributions, also some examples to get you started." />
	<link rel="canonical" href="https://www.debugpoint.com/install-ffmpeg-ubuntu/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="How to Install FFmpeg in Ubuntu and Other Linux" />
	<meta property="og:description" content="A tutorial on how you can install the FFmpeg package in Ubuntu and other Linux distributions, also some examples to get you started." />
	<meta property="og:url" content="https://www.debugpoint.com/install-ffmpeg-ubuntu/" />
	<meta property="og:site_name" content="DebugPoint.com" />
	<meta property="article:publisher" content="http://www.facebook.com/DebugPoint" />
	<meta property="article:published_time" content="2022-11-11T03:39:00+00:00" />
	<meta property="article:modified_time" content="2022-11-11T03:41:21+00:00" />
	<meta property="og:image" content="https://www.debugpoint.com/wp-content/uploads/2022/06/ffmpeg1.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="675" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Arindam" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@_arindam" />
	<meta name="twitter:site" content="@_arindam" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/#article","isPartOf":{"@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/"},"author":{"name":"Arindam","@id":"https://www.debugpoint.com/#/schema/person/cf2cc0ac61916cf8859959ee4f68aadc"},"headline":"How to Install FFmpeg in Ubuntu and Other Linux","datePublished":"2022-11-11T03:39:00+00:00","dateModified":"2022-11-11T03:41:21+00:00","mainEntityOfPage":{"@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/"},"wordCount":570,"commentCount":0,"publisher":{"@id":"https://www.debugpoint.com/#organization"},"image":{"@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/#primaryimage"},"thumbnailUrl":"https://www.debugpoint.com/wp-content/uploads/2022/06/ffmpeg1.jpg","keywords":["ffmpeg"],"articleSection":["Tutorials"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.debugpoint.com/install-ffmpeg-ubuntu/#respond"]}]},{"@type":"WebPage","@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/","url":"https://www.debugpoint.com/install-ffmpeg-ubuntu/","name":"How to Install FFmpeg in Ubuntu and Other Linux","isPartOf":{"@id":"https://www.debugpoint.com/#website"},"primaryImageOfPage":{"@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/#primaryimage"},"image":{"@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/#primaryimage"},"thumbnailUrl":"https://www.debugpoint.com/wp-content/uploads/2022/06/ffmpeg1.jpg","datePublished":"2022-11-11T03:39:00+00:00","dateModified":"2022-11-11T03:41:21+00:00","description":"A tutorial on how you can install the FFmpeg package in Ubuntu and other Linux distributions, also some examples to get you started.","breadcrumb":{"@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.debugpoint.com/install-ffmpeg-ubuntu/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/#primaryimage","url":"https://www.debugpoint.com/wp-content/uploads/2022/06/ffmpeg1.jpg","contentUrl":"https://www.debugpoint.com/wp-content/uploads/2022/06/ffmpeg1.jpg","width":1200,"height":675},{"@type":"BreadcrumbList","@id":"https://www.debugpoint.com/install-ffmpeg-ubuntu/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.debugpoint.com/"},{"@type":"ListItem","position":2,"name":"Tutorials","item":"https://www.debugpoint.com/category/tutorials/"},{"@type":"ListItem","position":3,"name":"How to Install FFmpeg in Ubuntu and Other Linux"}]},{"@type":"WebSite","@id":"https://www.debugpoint.com/#website","url":"https://www.debugpoint.com/","name":"DebugPoint.com","description":"Technology that Matters","publisher":{"@id":"https://www.debugpoint.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.debugpoint.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://www.debugpoint.com/#organization","name":"DebugPoint.com","url":"https://www.debugpoint.com/","logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.debugpoint.com/#/schema/logo/image/","url":"https://www.debugpoint.com/wp-content/uploads/2021/07/dp-logo-2021-base3-retina.png","contentUrl":"https://www.debugpoint.com/wp-content/uploads/2021/07/dp-logo-2021-base3-retina.png","width":735,"height":60,"caption":"DebugPoint.com"},"image":{"@id":"https://www.debugpoint.com/#/schema/logo/image/"},"sameAs":["http://www.facebook.com/DebugPoint","https://twitter.com/_arindam"]},{"@type":"Person","@id":"https://www.debugpoint.com/#/schema/person/cf2cc0ac61916cf8859959ee4f68aadc","name":"Arindam","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.debugpoint.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=96&d=wavatar&r=g","contentUrl":"https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=96&d=wavatar&r=g","caption":"Arindam"},"description":"Creator of debugpoint.com. All time Linux user and open-source supporter. Connect with me via Telegram, Twitter, LinkedIn, or send us an email.","sameAs":["https://www.debugpoint.com","https://twitter.com/_arindam"],"url":"https://www.debugpoint.com/author/admin1/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />

<link rel="alternate" type="application/rss+xml" title="DebugPoint.com &raquo; Feed" href="https://www.debugpoint.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="DebugPoint.com &raquo; Comments Feed" href="https://www.debugpoint.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="DebugPoint.com &raquo; How to Install FFmpeg in Ubuntu and Other Linux Comments Feed" href="https://www.debugpoint.com/install-ffmpeg-ubuntu/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css' href='https://www.debugpoint.com/wp-includes/css/dist/block-library/style.min.css?ver=ace0b72f8510807974c54019f37d3bc2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://www.debugpoint.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.17' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://www.debugpoint.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=ace0b72f8510807974c54019f37d3bc2' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://www.debugpoint.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link data-minify="1" rel='stylesheet' id='same-category-posts-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/plugins/same-category-posts/same-category-posts.css?ver=1660756792' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='wpdiscuz-frontend-css-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/plugins/wpdiscuz/themes/default/style.css?ver=1660756792' type='text/css' media='all' />
<style id='wpdiscuz-frontend-css-inline-css' type='text/css'>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</style>
<link data-minify="1" rel='stylesheet' id='wpdiscuz-fa-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/css/fa.min.css?ver=1660486044' type='text/css' media='all' />
<link rel='stylesheet' id='wpdiscuz-combo-css-css' href='https://www.debugpoint.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-combo.min.css?ver=ace0b72f8510807974c54019f37d3bc2' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='boombox-styles-min-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/themes/boombox/js/plugins/plugins.min.css?ver=1660486031' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='boombox-icomoon-style-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/themes/boombox/fonts/icon-fonts/icomoon/icons.min.css?ver=1660486031' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='boombox-primary-style-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/themes/boombox/css/style.min.css?ver=1660486031' type='text/css' media='all' />
<style id='boombox-primary-style-inline-css' type='text/css'>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</style>
<link data-minify="1" rel='stylesheet' id='jetpack_css-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1660756792' type='text/css' media='all' />
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>

<!-- Google Analytics snippet added by Site Kit -->
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-53016023-1' id='google_gtagjs-js' async></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.debugpoint.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-53016023-1", {"anonymize_ip":true});
gtag("config", "G-0P8HHR1JXV");
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<link rel="https://api.w.org/" href="https://www.debugpoint.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.debugpoint.com/wp-json/wp/v2/posts/9869" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.debugpoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.debugpoint.com/wp-includes/wlwmanifest.xml" />

<link rel='shortlink' href='https://www.debugpoint.com/?p=9869' />
<link rel="alternate" type="application/json+oembed" href="https://www.debugpoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.debugpoint.com%2Finstall-ffmpeg-ubuntu%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.debugpoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.debugpoint.com%2Finstall-ffmpeg-ubuntu%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.87.0" /><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.debugpoint.com/?wordfence_lh=1&hid=7B85DF240E60D486C605B680F72F70F0');
</script>	<style>img#wpstats{display:none}</style>
		
<link rel="preload" as="font" href="https://www.debugpoint.com/wp-content/themes/boombox/fonts/icon-fonts/icomoon/fonts/bb-icomoon.ttf" crossorigin>
<link rel="preload" as="font" href="https://www.debugpoint.com/wp-content/themes/boombox/scss/icon-fonts/fonts/ui-icomoon.ttf" crossorigin>
<link rel="preload" as="font" href="https://www.debugpoint.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/webfonts/fa-regular-400.woff2" crossorigin>
<link rel="preload" as="font" href="https://www.debugpoint.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/webfonts/fa-solid-900.woff2" crossorigin>
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="amphtml" href="https://www.debugpoint.com/install-ffmpeg-ubuntu/?amp=1">
<!-- Google AdSense snippet added by Site Kit -->
<script type="rocketlazyloadscript" async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-1235852655833346" crossorigin="anonymous" data-rocket-type="text/javascript"></script>

<!-- End Google AdSense snippet added by Site Kit -->
<link rel="preload" href="/fonts/Nunito-Regular.woff" as="font" type="font/woff2" crossorigin><link rel="icon" href="https://www.debugpoint.com/wp-content/uploads/2021/07/cropped-drawing2-site-icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.debugpoint.com/wp-content/uploads/2021/07/cropped-drawing2-site-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.debugpoint.com/wp-content/uploads/2021/07/cropped-drawing2-site-icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.debugpoint.com/wp-content/uploads/2021/07/cropped-drawing2-site-icon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			pre {
    background: #edeff1;
    padding: 0.5em;
    border-left: 4px solid green;
	font-size: 14px;
	/*box-shadow: 5px 5px 5px 0px rgba(0, 0, 0, 0.2), 0 5px 10px 0 rgba(0, 0, 0, 0.19);*/
}

.mywarn1 {
    background-color: lightgrey;
    border-left: 4px solid red;
    padding: 0.5em;
}

.mynote1 {
    background-color: #ffffcc;
    border-left: 4px solid #ffeb3b;
    padding: 0.5em;
}


.cooldiv1 {
    background: linear-gradient(90deg, rgba(28,113,216,1) 0%, rgba(48,200,119,1) 100%);
    padding: 4px 5px 4px 10px;
    font-size: 100%;
    color: white;
	border-radius: 3px;
}

.cooldiv2
{
    background: linear-gradient(90deg, #4275b2 0%, #4eaa88 100%);
    border: none;
    font-size: 100%;
    margin-bottom: 0px;
    color: white;
}

.cooldiv-warning {
    background: linear-gradient(90deg, rgb(205, 32, 31) 0%, rgb(247, 119, 55) 100%);
    padding: 4px 5px 4px 10px;
    font-size: 100%;
    color: white;
    border-radius: 3px;
}

.cooldivold
{
    background: linear-gradient(90deg, #200122 0%, #6f0000 100%);
    border: none;
    font-size: 100%;
    margin-bottom: 0px;
    color: white;
}

.bb-ui-icon-search {color:#b60400;}

/**Px-Lab Support: make the content font weight 300 **/
body, html {
    font-weight: 400;
	line-height:1.6;
}

.widget-title {
	color:#b60400;
}

/* Zoom-n-rotate Container */
.branding img {
  transition: transform .5s ease-in-out;
}

/* The Transformation */
.branding:hover img {
  transform: scale(1.2) rotate(2deg);
}

.s-post-content img {
	box-shadow: 5px 5px 5px 0px rgba(0, 0, 0, 0.2), 0 5px 10px 0 rgba(0, 0, 0, 0.19);
	
}

/* announcement div */

.ann-div-1 {
    border: 1px solid;
    padding: 12px 1px 1px 15px;
    background-color: aliceblue;
    border-color: cadetblue;
    border-radius: 5px;
}

.wp-block-image figcaption {
	color: grey;
	
}

.bb-post-single .s-post-content p {
    margin-top: 1rem;
    line-height: 1.5em;
    font-size: 16px;
}

.bb-post-single .s-post-content li {
    line-height: 1.5em;
    font-size: 16px;
 
}

.bb-post-single .s-post-content h2 {
    font-size: 1.5em;
 
}

.bb-post-single .s-post-content h3 {
    font-size: 1.17em; 
}

.container {width:1600px;}

@font-face {
font-family: 'Nunito';
src: url('https://www.debugpoint.com/fonts/Nunito-Regular.woff') format('woff');
font-weight: normal;
font-style: normal;
	font-display:swap;
}

body, html {
font-family:"Nunito";
}


 
.dp-home-main-block {
   border-style: solid;
    border-color: lightgray;
    border-width: 1px;
    border-radius: 10px;
	background-color: white;
	    margin-top: 10px;
    padding: 20px 5px 5px 15px;
  }  
  
  .dp-home-main-block-sub {
    max-width: 1700px;
    margin-left: auto;
    margin-right: auto;
    padding: 20px;
}

.dp-home-main-block h2 {
    font-weight: 600;
    font-size: 20px;
    padding: 1PX 1PX 12px 2px;
    border-bottom: 1px solid #dadce0;
	
}
  
.dp-home-main-block li {
    padding: 0px 0px 5px 0px;
}

.dp-gnews-link {
margin-bottom: 16px;
margin-left: auto;
margin-right: auto;
max-width: 750px;
padding-left: 10px;
padding-right: 10px;
background-color: #ecfbf1;
font-size: 1.1em;
line-height: 1.5em;
border-radius: 10px;
border-color: #d7e6d7;
border-width: 0.1px;
}

.dp-telegram-link {
margin-bottom: 16px;
margin-left: auto;
margin-right: auto;
max-width: 750px;
padding-left: 10px;
padding-right: 10px;
background-color: aliceblue;
font-size: 1.1em;
line-height: 1.5em;
border-radius: 10px;
border-color: #bfd5fd;
border-width: 0.1px;
}

.bb-next-prev-pagination.pg-lg .page-link, .bb-next-prev-pagination.pg-md .page-link {color: whitesmoke;}		</style>
			</head>

	<body class="post-template-default single single-post postid-9869 single-format-standard wp-custom-logo boombox-theme-light two-sidebar sidebar-1_3-1_4 right-sidebar badge-face-text badges-outside-left bb-cards-view material-cards">


		
	<div id="mobile-nav-bg"></div>
	<div id="mobile-navigation" class="bb-mobile-navigation">
		<button id="menu-close" class="close">
			<i class="bb-icon bb-ui-icon-close"></i>
		</button>
		<div class="holder">
			<div class="more-menu">
				<div class="more-menu-header">
									</div>
					<nav class="main-navigation">
		<ul id="menu-social_links" class=""><li id="menu-item-832" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-832 menu-item-icon"><a href="http://www.debugpoint.com/feed"><i class="bb-icon bb-icon-rss"></i>RSS</a></li>
<li id="menu-item-10578" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10578 menu-item-icon"><a href="https://t.me/debugpoint"><i class="bb-icon bb-icon-comments"></i>Telegram Channel</a></li>
<li id="menu-item-10577" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10577 menu-item-icon"><a href="https://news.google.com/publications/CAAqBwgKMOCfmgsw-qmyAw"><i class="bb-icon bb-icon-newspaper"></i>Google News</a></li>
<li id="menu-item-831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-831 menu-item-icon"><a href="https://twitter.com/DebugPoint"><i class="bb-icon bb-icon-at"></i>Twitter</a></li>
<li id="menu-item-833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-833 menu-item-icon"><a href="https://www.youtube.com/c/Debugpoint"><i class="bb-icon bb-icon-youtube"></i>YouTube</a></li>
<li id="menu-item-829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-829 menu-item-icon"><a href="http://www.facebook.com/DebugPoint"><i class="bb-icon bb-icon-facebook-square"></i>Facebook</a></li>
<li id="menu-item-830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-830 menu-item-icon"><a href="https://floss.social/@debugpoint"><i class="bb-icon bb-icon-at"></i>Mastodon</a></li>
<li id="menu-item-10579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10579 menu-item-icon"><a href="https://www.reddit.com/r/debugpoint/"><i class="bb-icon bb-icon-zombify_personality_quiz"></i>r/debugpoint</a></li>
<li id="menu-item-10580" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10580 menu-item-icon"><a href="http://contact@debugpoint.com"><i class="bb-icon bb-icon-envelope"></i>Email</a></li>
</ul>	</nav>
		<nav class="main-navigation">
		<ul id="menu-top_menu_generic" class=""><li id="menu-item-10188" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10188"><a href="#">Guide &#038; Review</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-930" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-930 menu-item-icon"><a href="https://www.debugpoint.com/category/tutorials/"><i class="bb-icon bb-icon-book2"></i>All Tutorial(s)</a></li>
	<li id="menu-item-10189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10189"><a href="https://www.debugpoint.com/tag/linux-distro-review">Linux Distro Review</a></li>
	<li id="menu-item-10190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10190"><a href="https://www.debugpoint.com/category/review/">Complete Review Index</a></li>
</ul>
</li>
<li id="menu-item-927" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-927 menu-item-icon"><a href="https://www.debugpoint.com/category/apps/"><i class="bb-icon bb-icon-app-store"></i>App</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-3559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3559"><a href="https://www.debugpoint.com/category/top-list/">Top List Index</a></li>
	<li id="menu-item-10191" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10191"><a href="https://www.debugpoint.com/tag/top-10-list">Top 10 List</a></li>
	<li id="menu-item-10192" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10192"><a href="https://www.debugpoint.com/tag/ubuntu-apps">Ubuntu Apps</a></li>
	<li id="menu-item-10194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10194"><a href="https://www.debugpoint.com/tag/gnome-apps">GNOME Apps</a></li>
	<li id="menu-item-10193" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10193"><a href="https://www.debugpoint.com/tag/kde-apps">KDE Apps</a></li>
	<li id="menu-item-480" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-480"><a href="https://www.debugpoint.com/category/libreoffice/">LibreOffice</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li id="menu-item-481" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-481"><a href="https://www.debugpoint.com/category/libreoffice/libreoffice-calc/">Calc</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-3310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3310 menu-item-icon"><a href="https://www.debugpoint.com/category/desktop-environment/themes/"><i class="bb-icon bb-icon-paint-brush"></i>Theme</a></li>
<li id="menu-item-5024" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5024 menu-item-icon"><a href="https://www.debugpoint.com/category/distributions/"><i class="bb-icon bb-icon-tech1"></i>Distro</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-10111" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10111"><a href="#">Upcoming</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li id="menu-item-10925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10925"><a href="https://www.debugpoint.com/tag/fedora-37">Fedora 37</a></li>
		<li id="menu-item-10117" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10117"><a href="https://www.debugpoint.com/tag/elementary-os-7/">elementary OS 7 Horus</a></li>
	</ul>
</li>
	<li id="menu-item-10116" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10116"><a href="#">Current</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li id="menu-item-10926" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10926"><a href="https://www.debugpoint.com/tag/ubuntu-22-10">Ubuntu 22.10 (Kinetic Kudu)</a></li>
		<li id="menu-item-8087" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8087"><a href="https://www.debugpoint.com/tag/fedora-36">Fedora 36</a></li>
		<li id="menu-item-10114" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10114"><a href="https://www.debugpoint.com/tag/linux-mint-21/">Linux Mint 21.0 &#8211; Vanessa</a></li>
		<li id="menu-item-8040" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8040"><a href="https://www.debugpoint.com/tag/elementary-os-6">elementary OS 6</a></li>
	</ul>
</li>
	<li id="menu-item-8039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8039"><a href="https://www.debugpoint.com/tag/arch-linux">Arch Linux</a></li>
	<li id="menu-item-8684" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8684"><a href="https://www.debugpoint.com/tag/pop-os/">Pop!_OS</a></li>
	<li id="menu-item-8041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8041"><a href="https://www.debugpoint.com/tag/linux-distro-review">Distro Review</a></li>
	<li id="menu-item-8043" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8043"><a href="https://www.debugpoint.com/category/distributions/">View All Distros</a></li>
</ul>
</li>
<li id="menu-item-928" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-928 menu-item-icon"><a href="https://www.debugpoint.com/category/desktop-environment/"><i class="bb-icon bb-icon-tv"></i>DE</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-8037" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8037"><a href="https://debugpointnews.com/gnome-43-alpha/">GNOME 43</a></li>
	<li id="menu-item-8036" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8036"><a href="https://www.debugpoint.com/tag/kde-plasma-5-26">KDE Plasma 5.26</a></li>
	<li id="menu-item-8038" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8038"><a href="https://www.debugpoint.com/tag/xfce-4-18">Xfce 4.18</a></li>
	<li id="menu-item-8683" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8683"><a href="https://www.debugpoint.com/tag/lxqt/">LXQt</a></li>
	<li id="menu-item-8042" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8042"><a href="https://www.debugpoint.com/category/desktop-environment/">View All Desktop Env</a></li>
</ul>
</li>
<li id="menu-item-9343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9343 menu-item-icon"><a href="https://debugpointnews.com"><i class="bb-icon bb-icon-newspaper2"></i>News<span class="label new">New</span></a></li>
<li id="menu-item-4911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4911 menu-item-icon"><a href="https://www.debugpoint.com/category/development/"><i class="bb-icon bb-icon-code"></i>Dev</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-10113" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10113"><a href="https://www.debugpoint.com/tag/linux-kernel-6-1/">Linux Kernel 6.1 (RC phase)</a></li>
	<li id="menu-item-1464" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1464"><a href="https://www.debugpoint.com/libreoffice-basic-macro-tutorial-index/">LibreOffice Macro</a></li>
</ul>
</li>
<li id="menu-item-8142" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-8142"><a href="#">More</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-8143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8143 menu-item-icon"><a href="https://www.debugpoint.com/category/opinion/"><i class="bb-icon bb-icon-bullhorn"></i>Editorial and Opinion<span class="label hot">Hot</span></a></li>
	<li id="menu-item-929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-929 menu-item-icon"><a href="https://www.debugpoint.com/category/hardware/"><i class="bb-icon bb-icon-cogs"></i>Hardware</a></li>
</ul>
</li>
</ul>	</nav>
	
				<div class="more-menu-footer">

					
				</div>
			</div>

		</div>
	</div>
	
		<div id="page-wrapper" class="page-wrapper">

			
	<header class="bb-show-desktop-header bb-header header-desktop no-bottom top-shadow">

		<div class="bb-sticky bb-sticky-nav sticky-smart">
			<div class="top-header  medium full-width menu-center bb-sticky-el">
				<div class="container">

					
											<div class="h-component m-1 logo">
<div class="branding">
	<p class="site-title">
		<a href="https://www.debugpoint.com/">

								<img width="368" height="30" class="site-logo " src="https://www.debugpoint.com/wp-content/uploads/2021/07/dp-logo-2021-base3.png" alt="DebugPoint.com" srcset="https://www.debugpoint.com/wp-content/uploads/2021/07/dp-logo-2021-base3-retina.png 2x,https://www.debugpoint.com/wp-content/uploads/2021/07/dp-logo-2021-base3.png 1x" />
						</a>
	</p>

	</div></div>
											<div class="h-component m-2">

															<div class="bb-header-navigation header-item">
										<nav class="main-navigation">
		<ul id="menu-top_menu_generic-1" class=""><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10188"><a href="#">Guide &#038; Review</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-930 menu-item-icon"><a href="https://www.debugpoint.com/category/tutorials/"><i class="bb-icon bb-icon-book2"></i>All Tutorial(s)</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10189"><a href="https://www.debugpoint.com/tag/linux-distro-review">Linux Distro Review</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10190"><a href="https://www.debugpoint.com/category/review/">Complete Review Index</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-927 menu-item-icon"><a href="https://www.debugpoint.com/category/apps/"><i class="bb-icon bb-icon-app-store"></i>App</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3559"><a href="https://www.debugpoint.com/category/top-list/">Top List Index</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10191"><a href="https://www.debugpoint.com/tag/top-10-list">Top 10 List</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10192"><a href="https://www.debugpoint.com/tag/ubuntu-apps">Ubuntu Apps</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10194"><a href="https://www.debugpoint.com/tag/gnome-apps">GNOME Apps</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10193"><a href="https://www.debugpoint.com/tag/kde-apps">KDE Apps</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-480"><a href="https://www.debugpoint.com/category/libreoffice/">LibreOffice</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-481"><a href="https://www.debugpoint.com/category/libreoffice/libreoffice-calc/">Calc</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3310 menu-item-icon"><a href="https://www.debugpoint.com/category/desktop-environment/themes/"><i class="bb-icon bb-icon-paint-brush"></i>Theme</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5024 menu-item-icon"><a href="https://www.debugpoint.com/category/distributions/"><i class="bb-icon bb-icon-tech1"></i>Distro</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10111"><a href="#">Upcoming</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10925"><a href="https://www.debugpoint.com/tag/fedora-37">Fedora 37</a></li>
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10117"><a href="https://www.debugpoint.com/tag/elementary-os-7/">elementary OS 7 Horus</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10116"><a href="#">Current</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10926"><a href="https://www.debugpoint.com/tag/ubuntu-22-10">Ubuntu 22.10 (Kinetic Kudu)</a></li>
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8087"><a href="https://www.debugpoint.com/tag/fedora-36">Fedora 36</a></li>
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10114"><a href="https://www.debugpoint.com/tag/linux-mint-21/">Linux Mint 21.0 &#8211; Vanessa</a></li>
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8040"><a href="https://www.debugpoint.com/tag/elementary-os-6">elementary OS 6</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8039"><a href="https://www.debugpoint.com/tag/arch-linux">Arch Linux</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8684"><a href="https://www.debugpoint.com/tag/pop-os/">Pop!_OS</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8041"><a href="https://www.debugpoint.com/tag/linux-distro-review">Distro Review</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8043"><a href="https://www.debugpoint.com/category/distributions/">View All Distros</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-928 menu-item-icon"><a href="https://www.debugpoint.com/category/desktop-environment/"><i class="bb-icon bb-icon-tv"></i>DE</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8037"><a href="https://debugpointnews.com/gnome-43-alpha/">GNOME 43</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8036"><a href="https://www.debugpoint.com/tag/kde-plasma-5-26">KDE Plasma 5.26</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8038"><a href="https://www.debugpoint.com/tag/xfce-4-18">Xfce 4.18</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8683"><a href="https://www.debugpoint.com/tag/lxqt/">LXQt</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8042"><a href="https://www.debugpoint.com/category/desktop-environment/">View All Desktop Env</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9343 menu-item-icon"><a href="https://debugpointnews.com"><i class="bb-icon bb-icon-newspaper2"></i>News<span class="label new">New</span></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4911 menu-item-icon"><a href="https://www.debugpoint.com/category/development/"><i class="bb-icon bb-icon-code"></i>Dev</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10113"><a href="https://www.debugpoint.com/tag/linux-kernel-6-1/">Linux Kernel 6.1 (RC phase)</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1464"><a href="https://www.debugpoint.com/libreoffice-basic-macro-tutorial-index/">LibreOffice Macro</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-8142"><a href="#">More</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8143 menu-item-icon"><a href="https://www.debugpoint.com/category/opinion/"><i class="bb-icon bb-icon-bullhorn"></i>Editorial and Opinion<span class="label hot">Hot</span></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-929 menu-item-icon"><a href="https://www.debugpoint.com/category/hardware/"><i class="bb-icon bb-icon-cogs"></i>Hardware</a></li>
</ul>
</li>
</ul>	</nav>
									</div>
													</div>
					
										<div class="h-component r-1 has-mode-switcher has-search has-burger-icon">
						
<div class="bb-mode-switcher header-item">
	<a href="#" class="bb-mode-toggle bb-header-icon" role="button" rel="nofollow">
		<i class="bb-placeholder bb-icon bb-ui-icon-sun"></i>
		<i class="bb-day-mode-icon bb-icon bb-ui-icon-sun"></i>
		<i class="bb-night-mode-icon bb-icon bb-ui-icon-moon"></i>
	</a>
</div><div class="bb-header-search header-item bb-toggle bb-focus pos-right">
	<a class="form-toggle element-toggle element-focus bb-header-icon" href="#" role="button" data-toggle=".search-dropdown" data-focus=".search-form input">
		<i class="bb-icon bb-ui-icon-search"></i>
	</a>
	<div class="search-dropdown bb-header-dropdown toggle-content">
		<form role="search" method="get" class="search-form form" action="https://www.debugpoint.com/">
			<input type="search" class="pull-left" name="s" value="">
			<button class="search-submit pull-right"
			        type="submit">Search</button>
		</form>
	</div>
</div>

<a id="menu-button"
   class="header-item bb-header-icon menu-button pos-right"
   role="button"
   href="#">
	<i class="bb-ui-icon-burger-menu"></i>
</a>					</div>
					
				</div>

				
			</div>
			</div>
		
	</header>

	<div class="bb-show-mobile-header bb-sticky bb-sticky-nav sticky-classic">	<header class="bb-header header-mobile h-style h-style-left large bb-sticky-el">
		<div class="container header-row">
			<div class="header-row-layout">

				
				<div class="header-col header-c">
					
<div class="branding">
	<p class="site-title">
		<a href="https://www.debugpoint.com/">
								<img width="368" height="30" class="site-logo-mobile " src="https://www.debugpoint.com/wp-content/uploads/2021/07/dp-logo-2021-base3.png" alt="DebugPoint.com" srcset="https://www.debugpoint.com/wp-content/uploads/2021/07/dp-logo-2021-base3-retina.png 2x,https://www.debugpoint.com/wp-content/uploads/2021/07/dp-logo-2021-base3.png 1x" />

						</a>
	</p>
</div>				</div>

									<div class="header-col header-r">
						<div class="bb-header-search header-item bb-toggle bb-focus pos-right">
	<a class="form-toggle element-toggle element-focus bb-header-icon" href="#" role="button" data-toggle=".search-dropdown" data-focus=".search-form input">
		<i class="bb-icon bb-ui-icon-search"></i>
	</a>
	<div class="search-dropdown bb-header-dropdown toggle-content">
		<form role="search" method="get" class="search-form form" action="https://www.debugpoint.com/">
			<input type="search" class="pull-left" name="s" value="">
			<button class="search-submit pull-right"
			        type="submit">Search</button>
		</form>
	</div>
</div>

<a id="menu-button"
   class="header-item bb-header-icon menu-button pos-right"
   role="button"
   href="#">
	<i class="bb-ui-icon-burger-menu"></i>
</a>					</div>
				
			</div>
		</div>
	</header>
</div>
			<main id="main" role="main">

				<div class="container single-container s-mt-sm">

		<article id="post-9869" class="single post bb-post-single style1 post-9869 type-post status-publish format-standard has-post-thumbnail category-tutorials tag-ffmpeg" data-post-id="9869" itemscope="" itemtype="http://schema.org/Article">
		<div class="single-top-container bb-mb-el mb-xs">
			<nav class="s-post-breadcrumb bb-breadcrumb clr-style1">	<div class="breadcrumb-inner" role="navigation" aria-label="Breadcrumb">
		<ol itemscope itemtype="http://schema.org/BreadcrumbList">
							<li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">

					<a class="ordinal-item" itemprop="item" href="https://www.debugpoint.com/" >
													<span itemprop="name">Home</span>
											</a>
					<meta itemprop="position" content="1" />
				</li>
							<li class="ordinal-item" itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
					<i class="sep-icon bb-icon bb-ui-icon-angle-right"></i>					<a itemprop="item" href="https://www.debugpoint.com/category/tutorials/">
						<span itemprop="name">Tutorials</span>
					</a>
					<meta itemprop="position" content="2" />
				</li>
							<li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
					<i class="sep-icon bb-icon bb-ui-icon-angle-right"></i>					<a itemprop="item" href="https://www.debugpoint.com/install-ffmpeg-ubuntu/" class="last-item"><span itemprop="name">How to Install FFmpeg in Ubuntu and Other Linux</span></a>
					<meta itemprop="position" content="3">
				</li>
			
		</ol>
	</div>
</nav>		</div>

		<div class="single-main-container">
			<div class="bb-row">
				<div class="bb-col col-content">
					<div class="bb-row">
						<div class="bb-col col-site-main">
							<div class="site-main" role="main">

																	<div class="s-post-main mb-md bb-mb-el bb-card-item">

																				<header class="entry-header s-post-header bb-mb-el">

											
<div class="s-post-microdata mf-hide">
	
		<span itemprop="image" itemscope="" itemtype="https://schema.org/ImageObject">
		<!-- featured image -->
		<meta itemprop="url" content="https://www.debugpoint.com/wp-content/uploads/2022/06/ffmpeg1.jpg">
		<!-- featured image W -->
		<meta itemprop="width" content="768">
		<!-- featured image H -->
		<meta itemprop="height" content="432">
	</span>
	
	<span itemprop="publisher" itemscope="" itemtype="https://schema.org/Organization">
				<span itemprop="logo" itemscope="" itemtype="https://schema.org/ImageObject">
			<meta itemprop="url" content="https://www.debugpoint.com/wp-content/uploads/2021/07/dp-logo-2021-base3.png">
		</span>
				<meta itemprop="name" content="DebugPoint.com">
		<meta itemprop="url" content="https://www.debugpoint.com/">
	</span>
	
	<time itemprop="datePublished" datetime="2022-11-11T09:09:00+05:30">3 mins ago</time>
	<time itemprop="dateModified" datetime="2022-11-11T09:11:21+05:30">26 seconds ago</time>
	<meta itemscope="" content="" itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.debugpoint.com/install-ffmpeg-ubuntu/">
</div>
<div class="s-post-header-top d-table-center-sm bb-mb-el">
	
	<div class="d-table-cell text-left-sm"><p class="bb-cat-links size-lg s-post-cat-links" itemprop="keywords"><a href="https://www.debugpoint.com/category/tutorials/" rel="category tag">Tutorials</a></p></div>
</div><h1 class="entry-title s-post-title bb-mb-el" itemprop="headline">How to Install FFmpeg in Ubuntu and Other Linux</h1><h2 class="entry-summary entry-sub-title s-post-summary bb-mb-el"><!--googleoff: index--><span class="bb-reading-time md"><span class="bb-clock bb-icon bb-ui-icon-clock"></span><span class="bb-text">3 min</span></span><!--googleon: index--></h2>
<hr class="bb-separator s-post-header-sep bb-mb-el" />
										</header>

																				<div class="s-post-meta-block bb-mb-el">
											<div class="post-meta-content row">
												<div class="d-table-center-sm">

													<div class="col-l d-table-cell col-md-6 col-sm-6 text-left-sm"><div class="bb-author-vcard-mini size-md" itemprop="author" itemscope="" itemtype="http://schema.org/Person"><div class="author-avatar mf-hide"><a href="https://www.debugpoint.com/author/admin1/"><img alt='Arindam' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=74&#038;d=wavatar&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=148&#038;d=wavatar&#038;r=g 2x" class='avatar avatar-74 photo lazyload' height='74' width='74' itemprop="image" decoding='async'/><noscript><img alt='Arindam' src='https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=74&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=148&#038;d=wavatar&#038;r=g 2x' class='avatar avatar-74 photo lazyload' height='74' width='74' itemprop="image" decoding='async'/></noscript></a></div><div class="author-info">
		<span class="auth-name mf-hide">
			<span class="auth-byline">by</span>
			<a class="auth-url" href="https://www.debugpoint.com/author/admin1/" itemprop="url">
				<span itemprop="name">Arindam</span>
			</a>
		</span><span class="auth-posted-on"><time class="entry-date published mf-hide" datetime="2022-11-11T09:09:00+05:30">3 mins ago</time><time class="entry-date updated" datetime="2022-11-11T09:11:21+05:30">26 seconds ago</time></span></div></div></div>
												</div>
											</div>
										</div>

										
<div itemprop="articleBody" class="s-post-content s-post-small-el bb-mb-el"><!-- dp_post_top_leader_1 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="7379524311"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<p></p>
<p><strong>This tutorial outlines the steps required to install FFmpeg in Ubuntu and Other Linux systems.</strong></p>



<span id="more-9869"></span>



<p>The ffmpeg is a collection library and software program to manipulate multimedia files. The entire ffmpeg is a robust set of libraries that allows you to convert, stream, and manipulate audio and video files. Many frontend Linux applications use it as a backend and hence depend on it. For example, a screen recording application may need ffmpeg to convert recorded streams to gif images.</p>



<p>Popular applications and services that use FFmpeg are VLC Media Player, YouTube, Blender, Kodi, Shotcut, and Handbrake &#8211; to name a few.</p>



<p>Fun fact: NASA&#8217;s Mars 2020 mission rover Perseverance used FFmpeg to complete and process images and video before beaming back to Earth!</p>



<h2>About ffmpeg package</h2>



<p>The <a href="https://ffmpeg.org/" target="_blank" rel="noreferrer noopener">ffmpeg</a> itself is a powerful program as a command-line utility. It is available for Linux, Windows, and macOS and supports many architectures. It is written in C and Assembly, providing extensive performance and a cross-platform utility.</p>



<h3>The Core</h3>



<p>The core of ffmpeg is the command-line utility or programs. They can be used on the command line or called from any programming language. For example, you can use these from your shell program, python script, etc.</p>



<ul>
<li><strong>ffmpeg</strong>: Used to convert audio and video streams, including sources from LIVE streams such as TV cards</li>



<li><strong>ffplay</strong>: Media player bundled in this package to play media</li>



<li><strong>ffprobe</strong>: Command line tool to show media information &#8211; can output as txtm csv, xml, json formats</li>
</ul>



<h2>FFmpeg Installation</h2>



<p>Installing FFmpeg is easy in Ubuntu and other Linux distributions. Open a terminal prompt and run the following commands to install.</p>



<h3>Ubuntu and similar distro</h3>



<pre class="wp-block-preformatted">sudo apt install ffmpeg</pre>



<h3>Fedora</h3>



<p>For Fedora Linux, you need to add the <a href="https://www.debugpoint.com/2020/07/enable-rpm-fusion-fedora-rhel-centos/" target="_blank" rel="noreferrer noopener">RPM Fusion repo</a> for FFmpeg. The official Fedora repo doesn&#8217;t have the FFmpeg package. </p>



<pre class="wp-block-preformatted">sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm</pre>



<pre class="wp-block-preformatted">sudo dnf install https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-</pre>



<pre class="wp-block-preformatted">sudo dnf install ffmpeg</pre>



<h3>Arch Linux</h3>



<pre class="wp-block-preformatted">pacman -S ffmpeg</pre>



<p>After the successful installation, you can verify the installation using the below command.</p>



<pre class="wp-block-preformatted">ffmpeg --version</pre>


<div class="wp-block-image">
<figure class="aligncenter size-large"><a href="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux.jpg"><img decoding="async" width="1024" height="632" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux-1024x632.jpg" alt="FFmpeg installed in Ubuntu Linux" class="wp-image-9873 lazyload" data-srcset="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux-1024x632.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux-300x185.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux-768x474.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux.jpg 1075w" sizes="(max-width: 1024px) 100vw, 1024px" /><noscript><img decoding="async" width="1024" height="632" src="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux-1024x632.jpg" alt="FFmpeg installed in Ubuntu Linux" class="wp-image-9873 lazyload" srcset="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux-1024x632.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux-300x185.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux-768x474.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-installed-in-Ubuntu-Linux.jpg 1075w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></a><figcaption class="wp-element-caption">FFmpeg installed in Ubuntu Linux</figcaption></figure></div>


<h2>Example: How to do basic tasks using ffmpeg</h2>



<p>First, let me give you a simple example of the basic syntax. Consider the following example. It simply converts an mp4 file to mkv file. </p>



<ol>
<li><strong>Convert a basic video file</strong></li>
</ol>



<pre class="wp-block-preformatted">ffmpeg -i big_buck_bunny.mp4 big_buck_bunny.mkv</pre>



<p>Of course, this is the easiest method, but it&#8217;s not complete because it doesn&#8217;t have the bit rate, resolution and other attributes of the video file required for the conversion.</p>



<ol start="2">
<li><strong>Convert an audio file </strong></li>
</ol>



<p>Secondly, you can convert an audio file using a similar command.</p>



<pre class="wp-block-preformatted">ffmpeg -i sunny_day.ogg sunny_day.mp3</pre>



<ol start="3">
<li><strong>Convert with an audio and video codec</strong></li>
</ol>



<p>Finally, the following example can convert a video file using specified codecs. The parameter <code>-c</code> with <code>a</code> or <code>v</code> defines audio and video, respectively. The below command uses <code>libvpx</code> video and <code>libvorbis</code> audio codec for conversion.</p>



<pre class="wp-block-preformatted">ffmpeg -i big_buck_bunny.mp4 -c:v libvpx -c:a libvorbis big_buck_bunny.webm</pre>



<h2>How to find out about the available codecs, encoders and decoders in your system?</h2>



<h3>List all codecs</h3>



<p>To list all the codecs available, run the below command.</p>



<pre class="wp-block-preformatted">ffmpeg -codecs</pre>



<p>This command lists all the codecs available with their capability, whether they support decoding or encoding, etc. Moreover, they are identified with the position as per the below table.</p>



<pre class="wp-block-preformatted">D..... = Decoding supported<br>.E.... = Encoding supported<br>..V... = Video codec<br>..A... = Audio codec<br>..S... = Subtitle codec<br>...I.. = Intra frame-only codec<br>....L. = Lossy compression<br>.....S = Lossless compression</pre>


<div class="wp-block-image">
<figure class="aligncenter size-large"><a href="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list.jpg"><img decoding="async" width="1024" height="1022" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-1024x1022.jpg" alt="FFmpeg Codec list" class="wp-image-9874 lazyload" data-srcset="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-1024x1022.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-300x300.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-150x150.jpg 150w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-768x767.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-370x370.jpg 370w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list.jpg 1194w" sizes="(max-width: 1024px) 100vw, 1024px" /><noscript><img decoding="async" width="1024" height="1022" src="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-1024x1022.jpg" alt="FFmpeg Codec list" class="wp-image-9874 lazyload" srcset="https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-1024x1022.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-300x300.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-150x150.jpg 150w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-768x767.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list-370x370.jpg 370w, https://www.debugpoint.com/wp-content/uploads/2022/06/FFmpeg-Codec-list.jpg 1194w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></a><figcaption class="wp-element-caption">FFmpeg Codec list</figcaption></figure></div>


<h3>List all encoders</h3>



<p>Listing all the encoders is accessible via the below command.</p>



<pre class="wp-block-preformatted">ffmpeg -encoders</pre>



<h3>List all decoders</h3>



<p>Similarly, the decoders list you can get via the below command.</p>



<pre class="wp-block-preformatted">ffmpeg -decoders</pre>



<h3>Details</h3>



<p>You can also get more details about the encoders or decoders using the parameter -h.</p>



<pre class="wp-block-preformatted">ffmpeg -h decoder=mp3</pre>



<h2>Summary</h2>



<p>I hope you learned the basics of FFmpeg and its commands. You can learn more about the program via the official <a href="https://ffmpeg.org/documentation.html" target="_blank" rel="noreferrer noopener">documentation</a>.</p>
    <div style="font-style:normal;font-weight:700;" class="post-navigation-link-next wp-block-post-navigation-link has-medium-font-size"></div>
<p></p>
<!--google news and telegram link START -->
<div class="dp-gnews-link"><a href="https://news.google.com/publications/CAAqBwgKMOCfmgsw-qmyAw" target="_blank" rel="nofollow"><em>Add DebugPoint to your <strong>Google News</strong> feed. Follow us:</em>
<img style="box-shadow: none;" src="data:image/png;base64,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"></img>
</a></div>
<div class="dp-telegram-link"><a href="https://t.me/debugpoint" target="_blank" rel="nofollow"><em>Join our <strong>Telegram Channel</strong> and stay informed on the move.</strong></em>
<img style="box-shadow: none;" src="data:image/png;base64,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"></img>
</a></div>
<!--google news and telegram link END -->
<p></p>	
<!-- post_bottom_banner_resp -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="8619046127"
     data-ad-format="auto"></ins>
<script type="rocketlazyloadscript">
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	<p></p>

<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="8197723605"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<nav class="bb-next-prev-pagination s-post-next-prev-pg mb-md bb-mb-el pg-md"><h2 class="screen-reader-text">Post Pagination</h2><ul class="pg-list"><li class="pg-item bb-disabled page-nav prev-page"></li><li class="pg-item page-nav next-page"><a class="next-page-link page-link" href="https://www.debugpoint.com/install-libreoffice-base-ubuntu/" rel="next"><i class="bb-icon bb-ui-icon-chevron-right"></i><span class="text big-text">Next Post</span><span class="text small-text">Next</span></a></li></ul></nav>
<hr class="bb-separator bb-mb-el" /><div class="bb-tags mb-md bb-mb-el" itemprop="keywords"><a href="https://www.debugpoint.com/tag/ffmpeg/" rel="tag">ffmpeg</a></div>
									</div>
									
									<section class="bb-author-vcard s-post-small-el mb-md bb-mb-el">
				<div class="author" itemscope="" itemtype="http://schema.org/Person">
					<header>
						<div class="avatar auth-avatar circle-frame">
							<a href="https://www.debugpoint.com/author/admin1/"><img alt='Arindam' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=186&#038;d=wavatar&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=372&#038;d=wavatar&#038;r=g 2x" class='avatar avatar-186 photo lazyload' height='186' width='186' itemprop="image" decoding='async'/><noscript><img alt='Arindam' src='https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=186&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=372&#038;d=wavatar&#038;r=g 2x' class='avatar avatar-186 photo lazyload' height='186' width='186' itemprop="image" decoding='async'/></noscript></a>
						</div>
						
						<div class="header-info">
							<h3 class="auth-name">
								<span class="auth-byline">Posted by</span>
								<a class="auth-url" itemprop="url" href="https://www.debugpoint.com/author/admin1/">
									<span itemprop="name">Arindam</span>
								</a>
								
							</h3>
							
						</div>
					</header>
			
					<div class="author-info">
						<div class="auth-desc" itemprop="description">Creator of debugpoint.com. All time Linux user and open-source supporter. Connect with me via <a href="https://t.me/arindamgiri">Telegram</a>, <a href="https://twitter.com/_arindam">Twitter</a>, <a href="https://www.linkedin.com/in/arindam-giri/">LinkedIn</a>, or send us an <a href="mailto:contact@debugpoint.com">email</a>.</div>
						
					</div>
				</div>
			</section><section id="boombox_comments" class="bb-comments bb-card-item s-post-small-el mb-md bb-mb-el">    <div class="wpdiscuz_top_clearing"></div>
    <div id='comments' class='comments-area'><div id='respond' style='width: 0;height: 0;clear: both;margin: 0;padding: 0;'></div>    <div id="wpdcom" class="wpdiscuz_unauth wpd-default wpd-layout-2 wpd-comments-open">
                    <div class="wc_social_plugin_wrapper">
                            </div>
            <div class="wpd-form-wrap">
                <div class="wpd-form-head">
                                            <div class="wpd-sbs-toggle">
                            <i class="far fa-envelope"></i> <span class="wpd-sbs-title">Subscribe</span> <i class="fas fa-caret-down"></i>
                        </div>
                                            <div class="wpd-auth">
                                                <div class="wpd-login">
                                                    </div>
                    </div>
                </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://www.debugpoint.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Notify of </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" >
                                                                                    <option value="post">new follow-up comments</option>
                                                                                                                                <option value="all_comment" >new replies to my comments</option>
                                                                                </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                    <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" class="wpd-prim-button wpd_not_clicked" type="submit" value="&rsaquo;" name="wpdiscuz_subscription_button" />
                                </div> 
                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="b3c58d4f55" /><input type="hidden" name="_wp_http_referer" value="/install-ffmpeg-ubuntu/" />                            </form>
                                                </div>
                            <div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id='wpd-main-form-wrapper-0_0'>
                                        <form class="wpd_comm_form wpd_main_comm_form"
                      method="post" enctype="multipart/form-data" data-uploading="false">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap ">
                                                                                                        <div class="wpd-avatar">
                                        <img alt='guest' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/?s=56&#038;d=wavatar&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/?s=112&#038;d=wavatar&#038;r=g 2x" class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' decoding='async'/><noscript><img alt='guest' src='https://secure.gravatar.com/avatar/?s=56&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=112&#038;d=wavatar&#038;r=g 2x' class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' decoding='async'/></noscript>                                    </div>
                                                <div id="wpd-editor-wraper-0_0" style="display: none;">
                <div id="wpd-editor-char-counter-0_0"
                     class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-0_0">Label</label>
                <textarea id="wc-textarea-0_0" name="wc_comment"
                          class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-0_0"></div>
                        <div id="wpd-editor-toolbar-0_0">
                            <button title="Bold"
                        class="ql-bold"  ></button>
                                <button title="Italic"
                        class="ql-italic"  ></button>
                                <button title="Underline"
                        class="ql-underline"  ></button>
                                <button title="Strike"
                        class="ql-strike"  ></button>
                                <button title="Ordered List"
                        class="ql-list" value='ordered' ></button>
                                <button title="Unordered List"
                        class="ql-list" value='bullet' ></button>
                                <button title="Blockquote"
                        class="ql-blockquote"  ></button>
                                <button title="Code Block"
                        class="ql-code-block"  ></button>
                                <button title="Link"
                        class="ql-link"  ></button>
                                <button title="Source Code"
                        class="ql-sourcecode"  data-wpde_button_name='sourcecode'>{}</button>
                                <button title="Spoiler"
                        class="ql-spoiler"  data-wpde_button_name='spoiler'>[+]</button>
                            <div class="wpd-editor-buttons-right">
                <span class='wmu-upload-wrap' wpd-tooltip='Attach an image to this comment' wpd-tooltip-position='left'><label class='wmu-add'><i class='far fa-image'></i><input style='display:none;' class='wmu-add-files' type='file' name='wmu_files[]'  accept='image/*'/></label></span>            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot" style='display:none;'>
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"><div class='wmu-action-wrap'><div class='wmu-tabs wmu-images-tab wmu-hide'></div></div></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                    <input id="wc_name-0_0" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title="">
                <label for="wc_name-0_0" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                    <input id="wc_email-0_0" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" />
                <label for="wc_email-0_0" class="wpdlb">Email*</label>
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input id="wc_website-0_0" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" />
                    <label for="wc_website-0_0" class="wpdlb">Website</label>
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" />
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-0_0" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" />
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="0_0"
                           name="wpdiscuz_unique_id">
                    <p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1c0f8ded7e" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="171"/><script type="rocketlazyloadscript">document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p>                </form>
                        </div>
                <div id="wpdiscuz_hidden_secondary_form" style="display: none;">
                    <div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id='wpd-secondary-form-wrapper-wpdiscuzuniqueid' style='display: none;'>
                            <div class="wpd-secondary-forms-social-content"></div>
                <div class="clearfix"></div>
                                        <form class="wpd_comm_form wpd-secondary-form-wrapper"
                      method="post" enctype="multipart/form-data" data-uploading="false">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap ">
                                                                                                        <div class="wpd-avatar">
                                        <img alt='guest' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/?s=56&#038;d=wavatar&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/?s=112&#038;d=wavatar&#038;r=g 2x" class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' decoding='async'/><noscript><img alt='guest' src='https://secure.gravatar.com/avatar/?s=56&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=112&#038;d=wavatar&#038;r=g 2x' class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' decoding='async'/></noscript>                                    </div>
                                                <div id="wpd-editor-wraper-wpdiscuzuniqueid" style="display: none;">
                <div id="wpd-editor-char-counter-wpdiscuzuniqueid"
                     class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-wpdiscuzuniqueid">Label</label>
                <textarea id="wc-textarea-wpdiscuzuniqueid" name="wc_comment"
                          class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-wpdiscuzuniqueid"></div>
                        <div id="wpd-editor-toolbar-wpdiscuzuniqueid">
                            <button title="Bold"
                        class="ql-bold"  ></button>
                                <button title="Italic"
                        class="ql-italic"  ></button>
                                <button title="Underline"
                        class="ql-underline"  ></button>
                                <button title="Strike"
                        class="ql-strike"  ></button>
                                <button title="Ordered List"
                        class="ql-list" value='ordered' ></button>
                                <button title="Unordered List"
                        class="ql-list" value='bullet' ></button>
                                <button title="Blockquote"
                        class="ql-blockquote"  ></button>
                                <button title="Code Block"
                        class="ql-code-block"  ></button>
                                <button title="Link"
                        class="ql-link"  ></button>
                                <button title="Source Code"
                        class="ql-sourcecode"  data-wpde_button_name='sourcecode'>{}</button>
                                <button title="Spoiler"
                        class="ql-spoiler"  data-wpde_button_name='spoiler'>[+]</button>
                            <div class="wpd-editor-buttons-right">
                <span class='wmu-upload-wrap' wpd-tooltip='Attach an image to this comment' wpd-tooltip-position='left'><label class='wmu-add'><i class='far fa-image'></i><input style='display:none;' class='wmu-add-files' type='file' name='wmu_files[]'  accept='image/*'/></label></span>            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot" style='display:none;'>
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"><div class='wmu-action-wrap'><div class='wmu-tabs wmu-images-tab wmu-hide'></div></div></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                    <input id="wc_name-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title="">
                <label for="wc_name-wpdiscuzuniqueid" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                    <input id="wc_email-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" />
                <label for="wc_email-wpdiscuzuniqueid" class="wpdlb">Email*</label>
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input id="wc_website-wpdiscuzuniqueid" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" />
                    <label for="wc_website-wpdiscuzuniqueid" class="wpdlb">Website</label>
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" />
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-wpdiscuzuniqueid" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" />
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid"
                           name="wpdiscuz_unique_id">
                    <p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1c0f8ded7e" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_2" name="ak_js" value="190"/><script type="rocketlazyloadscript">document.getElementById( "ak_js_2" ).setAttribute( "value", ( new Date() ).getTime() );</script></p>                </form>
                        </div>
                </div>
                    </div>
            <p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>            <div id="wpd-threads" class="wpd-thread-wrapper">
                <div class="wpd-thread-head">
                    <div class="wpd-thread-info " data-comments-count="0">
                        <span class='wpdtc' title='0'>0</span> Comments                    </div>
                                        <div class="wpd-space"></div>
                    <div class="wpd-thread-filter">
                                                    <div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div>
                                                        <div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div>
                                                </div>
                </div>
                <div class="wpd-comment-info-bar">
                    <div class="wpd-current-view"><i class="fas fa-quote-left"></i> Inline Feedbacks</div>
                    <div class="wpd-filter-view-all">View all comments</div>
                </div>
                                <div class="wpd-thread-list">
                                        <div class="wpdiscuz-comment-pagination" style='display:none;'>
                                                    <div class="wpd-load-more-submit-wrap">
                                <button name="submit" data-lastparentid="0" class="wpd-load-more-submit wpd-loaded wpd-prim-button">
                                    Load More Comments                                </button>
                            </div>
                            <span id="wpdiscuzHasMoreComments" data-is_show_load_more="0"></span>
                                                </div>
                </div>
            </div>
                </div>
        </div>
    <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar-unauth"></div>
    <div id="wpdiscuz-comment-message" class="wpdiscuz-comment-message-unauth"></div>
    </section><nav class="bb-post-nav s-post-small-el bb-mb-el bb-no-play">
	<div class="row">
		<ul>
							<li class="next-page col-xs-12 col-md-6 col-lg-6">
					<span class="meta-nav">Next Post</span>

					<div class="pg-item bb-card-item">

													<div class="pg-thumb-col pg-col">
								<a class="pg-thumb" href="https://www.debugpoint.com/install-libreoffice-base-ubuntu/">
									<div class="bb-media-placeholder" style="padding-bottom:100%;"><img width="150" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/11/base-generic-head-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/11/base-generic-head-150x150.jpg 150w, https://www.debugpoint.com/wp-content/uploads/2022/11/base-generic-head-96x96.jpg 96w" sizes="(max-width: 150px) 100vw, 150px" /></div>								</a>
							</div>
						
						<div class="pg-content-col pg-col">
							<h6 class="post-title">
								<a href="https://www.debugpoint.com/install-libreoffice-base-ubuntu/">How to Install LibreOffice Base Database in Ubuntu and Other...</a>
							</h6>
							<div class="bb-author-vcard-mini post-author-vcard"><div class="author-info">
		<span class="auth-name">
			<span class="auth-byline">by</span>
			<a class="auth-url" href="https://www.debugpoint.com/author/admin1/">
				<span>Arindam</span>
			</a>
		</span></div></div>						</div>
					</div>
				</li>
			
		</ul>
	</div>
</nav>		<aside class="bb-other-posts bb-posts-more-from bb-post-collection hfeed mb-lg bb-mb-el hfeed post-list list list big-item bb-thumbnail-stretched">

							<h3 class="title">More From: <a href="https://www.debugpoint.com/category/tutorials/">Tutorials</a></h3>
			
						<ul class="post-items">
				
	<li class="post-item post-item-list">
		<article class="post bb-post bb-card-item post-11691 type-post status-publish format-standard has-post-thumbnail category-tutorials tag-libreoffice">

			<!-- thumbnail -->
			<div class="post-thumbnail">
				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">28</span></span></div>					<a href="https://www.debugpoint.com/install-libreoffice-base-ubuntu/"
					   title="How to Install LibreOffice Base Database in Ubuntu and Other Linux"  >
						<div class="bb-media-placeholder" style="padding-bottom:50%;"><img width="360" height="180" src="https://www.debugpoint.com/wp-content/uploads/2022/11/base-generic-head-360x180.jpg" class="attachment-boombox_image360x180 size-boombox_image360x180 wp-post-image" alt="" decoding="async" loading="lazy" /></div>					</a>

								</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<h2 class="entry-title"><a href="https://www.debugpoint.com/install-libreoffice-base-ubuntu/" rel="bookmark"  >How to Install LibreOffice Base Database in Ubuntu and Other Linux</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>


	<li class="post-item post-item-list">
		<article class="post bb-post bb-card-item post-8159 type-post status-publish format-standard has-post-thumbnail category-desktop-environment category-tutorials tag-arch-linux tag-enlightenment">

			<!-- thumbnail -->
			<div class="post-thumbnail">
				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">4.2k</span></span></div>					<a href="https://www.debugpoint.com/enlightenment-arch-linux-install/"
					   title="How to Install Enlightenment Desktop in Arch Linux [Complete Guide]"  >
						<div class="bb-media-placeholder" style="padding-bottom:50%;"><img width="360" height="180" src="https://www.debugpoint.com/wp-content/uploads/2021/09/ennewhead-360x180.jpg" class="attachment-boombox_image360x180 size-boombox_image360x180 wp-post-image" alt="" decoding="async" loading="lazy" /></div>					</a>

								</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<div class="bb-post-terms"><div class="post-meta bb-post-meta"><a href="https://www.debugpoint.com/enlightenment-arch-linux-install/#comments" class="post-meta-item post-comments"><i class="bb-icon bb-ui-icon-comment"></i><span class="count">2</span></a></div></div><h2 class="entry-title"><a href="https://www.debugpoint.com/enlightenment-arch-linux-install/" rel="bookmark"  >How to Install Enlightenment Desktop in Arch Linux [Complete Guide]</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>


	<li class="post-item post-item-list">
		<article class="post bb-post bb-card-item post-10556 type-post status-publish format-standard has-post-thumbnail category-distributions category-tutorials tag-linux-mint-20-3 tag-linux-mint-21">

			<!-- thumbnail -->
			<div class="post-thumbnail">
				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">4.5k</span></span></div>					<a href="https://www.debugpoint.com/upgrade-linux-mint-21-from-20-3/"
					   title="How to Upgrade to Linux Mint 21 from Mint 20.3 [Complete Guide]"  >
						<div class="bb-media-placeholder" style="padding-bottom:50%;"><img width="360" height="180" src="https://www.debugpoint.com/wp-content/uploads/2022/08/mint21up-360x180.jpg" class="attachment-boombox_image360x180 size-boombox_image360x180 wp-post-image" alt="" decoding="async" loading="lazy" /></div>					</a>

								</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<div class="bb-post-terms"><div class="post-meta bb-post-meta"><a href="https://www.debugpoint.com/upgrade-linux-mint-21-from-20-3/#comments" class="post-meta-item post-comments"><i class="bb-icon bb-ui-icon-comment"></i><span class="count">2</span></a></div></div><h2 class="entry-title"><a href="https://www.debugpoint.com/upgrade-linux-mint-21-from-20-3/" rel="bookmark"  >How to Upgrade to Linux Mint 21 from Mint 20.3 [Complete Guide]</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>

			</ul>
					</aside>

		    <aside class="bb-other-posts bb-posts-dont-miss bb-post-collection hfeed mb-xs bb-mb-el hfeed post-grid bb-thumbnail-stretched col-3">

                    <h2 class="title">DON&#039;T MISS</h2>
        
                <ul class="post-items">
            
	<li class="post-item post-item-grid">
		<article class="post bb-post bb-card-item post-11691 type-post status-publish format-standard has-post-thumbnail category-tutorials tag-libreoffice">

			<!-- thumbnail -->
			<div class="post-thumbnail">

				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">28</span></span></div>
					<a href="https://www.debugpoint.com/install-libreoffice-base-ubuntu/"
					   title="How to Install LibreOffice Base Database in Ubuntu and Other Linux"  >
						<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="360" height="270" src="https://www.debugpoint.com/wp-content/uploads/2022/11/base-generic-head-360x270.jpg" class="attachment-boombox_image360x270 size-boombox_image360x270 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/11/base-generic-head-360x270.jpg 360w, https://www.debugpoint.com/wp-content/uploads/2022/11/base-generic-head-200x150.jpg 200w" sizes="(max-width: 700px) 100vw, (max-width: 900px) 400px, (max-width: 1200px) 300px, 360px" /></div>					</a>

					
				
			</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<h2 class="entry-title"><a href="https://www.debugpoint.com/install-libreoffice-base-ubuntu/" rel="bookmark"  >How to Install LibreOffice Base Database in Ubuntu and Other Linux</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>


	<li class="post-item post-item-grid">
		<article class="post bb-post bb-card-item post-8159 type-post status-publish format-standard has-post-thumbnail category-desktop-environment category-tutorials tag-arch-linux tag-enlightenment">

			<!-- thumbnail -->
			<div class="post-thumbnail">

				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">4.2k</span></span></div>
					<a href="https://www.debugpoint.com/enlightenment-arch-linux-install/"
					   title="How to Install Enlightenment Desktop in Arch Linux [Complete Guide]"  >
						<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="360" height="270" src="https://www.debugpoint.com/wp-content/uploads/2021/09/ennewhead-360x270.jpg" class="attachment-boombox_image360x270 size-boombox_image360x270 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/09/ennewhead-360x270.jpg 360w, https://www.debugpoint.com/wp-content/uploads/2021/09/ennewhead-200x150.jpg 200w" sizes="(max-width: 700px) 100vw, (max-width: 900px) 400px, (max-width: 1200px) 300px, 360px" /></div>					</a>

					
				
			</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<div class="bb-post-terms"><div class="post-meta bb-post-meta"><a href="https://www.debugpoint.com/enlightenment-arch-linux-install/#comments" class="post-meta-item post-comments"><i class="bb-icon bb-ui-icon-comment"></i><span class="count">2</span></a></div></div><h2 class="entry-title"><a href="https://www.debugpoint.com/enlightenment-arch-linux-install/" rel="bookmark"  >How to Install Enlightenment Desktop in Arch Linux [Complete Guide]</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>

        </ul>
        
    </aside>
    															</div>
						</div>

						
<div class="bb-col col-sidebar-secondary" xmlns="http://www.w3.org/1999/html">
	<aside id="secondary-small" class="sidebar-secondary widget-area">
		<section  class="sticky-sidebar"></section><section id="custom_html-49" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- ad2_small_top_right -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="1716718128"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section><section id="custom_html-51" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- story1 exp-->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="1400854534"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section>	</aside>
</div>					</div>
				</div>

				<div class="bb-col col-sidebar">
	<aside id="secondary" class="sidebar widget-area">
		<section id="custom_html-36" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://t.me/debugpoint"><img width="400" height="120" alt="Join our Telegram channel and stay informed on the move." src="https://www.debugpoint.com/wp-content/uploads/2020/07/telegramjoin1.png" style="height:120px; width:400px;"></a></div></section>
		<section id="recent-posts-9" class="widget widget_recent_entries">
		<h4 class="widget-title">Recent Articles</h4>
		<ul>
											<li>
					<a href="https://www.debugpoint.com/install-ffmpeg-ubuntu/" aria-current="page">How to Install FFmpeg in Ubuntu and Other Linux</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/install-libreoffice-base-ubuntu/">How to Install LibreOffice Base Database in Ubuntu and Other Linux</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/enlightenment-arch-linux-install/">How to Install Enlightenment Desktop in Arch Linux [Complete Guide]</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/upgrade-linux-mint-21-from-20-3/">How to Upgrade to Linux Mint 21 from Mint 20.3 [Complete Guide]</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/linux-mint-21-review/">Linux Mint 21 Review: Still Fresh and Easiest Distro to Try</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/wget-not-found-error/">How to Fix: bash wget Command Not Found Error</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/mint-upgrade-tool/">Linux Mint Upgrade Tool &#8211; Here&#8217;s How it Works</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/sudo-command-not-found/">How to Fix: sudo Command Not Found Error</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/gnome-43/">GNOME 43: Top New Features and Release Wiki</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/fedora-37/">Fedora 37: Top New Features and Release Wiki</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/could-not-get-lock/">Fixing Could not get lock /var/lib/dpkg/lock Error in Ubuntu</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/systemd-or-init/">How to Find Systemd or Any Other init System in Linux</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/netflix-full-hd-1080p-ubuntu/">How to Enable Netflix Full HD (1080p) in Ubuntu and Other Linux</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/watch-netflix-linux/">How to Watch Netflix in Linux [Easy Guide]</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/systemd-journalctl/">How to use journalctl to View and Analyze Systemd Logs [With Examples]</a>
									</li>
					</ul>

		</section><section id="rss-5" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget rss-widget-feed" href="https://debugpointnews.com/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.debugpoint.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget rss-widget-title" href="https://debugpointnews.com/">Latest from: DebugPoint News</a></h4><ul><li><a class='rsswidget' href='https://debugpointnews.com/kde-plasma-5-27-outline-windows/'>KDE Plasma 5.27 Bringing Subtle Outline on Windows</a></li><li><a class='rsswidget' href='https://debugpointnews.com/peppermint-os-devuan-2022-11/'>Peppermint OS Devuan Latest Release Brings Nala Package Manager + More</a></li><li><a class='rsswidget' href='https://debugpointnews.com/weekly-roundup-22-12/'>DebugPoint Weekly Roundup #22.12: OpenSSL Fixes, Nitrux 2.5, elementary OS 7 Updates</a></li><li><a class='rsswidget' href='https://debugpointnews.com/openssl-3-0-7/'>OpenSSL 3.0.7 Fixes Two High-CVEs with Buffer Overflow</a></li></ul></section><section  class="sticky-sidebar"></section><section id="custom_html-38" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- dp_sidebar_resp_new -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="2725480046"
     data-ad-format="auto"></ins>
<script type="rocketlazyloadscript">
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section><section id="same-category-posts-10" class="widget same-category-posts"><h4 class="widget-title"><a href="https://www.debugpoint.com/tag/ffmpeg/">Related Articles</a></h4><ul>
<li class="same-category-post-item "><a class="post-title" href="https://www.debugpoint.com/a-complete-guide-to-create-gif-in-linux/" rel="bookmark" title="Permanent Link to A Complete Guide to Create GIF in Linux">A Complete Guide to Create GIF in Linux</a></li></ul>
</section>
	</aside>
</div>
			</div>
		</div>
	</article>
	
</div>

			<!--Div for sticky elements -->
			<div id="sticky-border"></div>
			</main>

							<footer id="footer" class="footer ">
					
<div class="footer-top">
	
	<div class="container">

				<div class="bb-featured-strip featured-carousel big-item outside-title mb-md">
		<ul>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/2-ways-fix-laptop-brightness-problem-ubuntu-linux/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2016/10/brightness-head-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2016/10/brightness-head-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2016/10/brightness-head-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">4 Ways to Fix the Laptop Brightness Problem...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/2-ways-fix-laptop-brightness-problem-ubuntu-linux/">
							4 Ways to Fix the Laptop Brightness Problem...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/best-linux-distributions-2022/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/05/bestlinux1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/05/bestlinux1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2022/05/bestlinux1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Top 10 Best Linux Distributions in 2022 For...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/best-linux-distributions-2022/">
							Top 10 Best Linux Distributions in 2022 For...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/windows-11-inspiration-linux-kde-plasma/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Windows 11 Look Inspired by KDE Plasma and...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/windows-11-inspiration-linux-kde-plasma/">
							Windows 11 Look Inspired by KDE Plasma and...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/ubuntu-should-choose-kde-plasma/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Should Ubuntu Adopt KDE Plasma as Default Desktop?...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/ubuntu-should-choose-kde-plasma/">
							Should Ubuntu Adopt KDE Plasma as Default Desktop?...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/how-enable-volume-power-control-amazon-fire-tv-stick/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2020/03/amazon-fire-2-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2020/03/amazon-fire-2-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2020/03/amazon-fire-2-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Enable Volume and Power Control in...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/how-enable-volume-power-control-amazon-fire-tv-stick/">
							How to Enable Volume and Power Control in...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/top-linux-distributions-kde-plasma/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2021/12/kde-top-10-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/12/kde-top-10-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2021/12/kde-top-10-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Top 10 Linux Distributions for KDE Plasma [Compared]</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/top-linux-distributions-kde-plasma/">
							Top 10 Linux Distributions for KDE Plasma [Compared]						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/beautiful-linux-distributions-2022/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/03/beauty-1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/03/beauty-1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2022/03/beauty-1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Top 10 Most Beautiful Linux Distributions [Featured]</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/beautiful-linux-distributions-2022/">
							Top 10 Most Beautiful Linux Distributions [Featured]						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/writing-a-macro-in-libreoffice-calc-getting-started/">
							<div class="bb-media-placeholder" style="padding-bottom:51%;"><img width="200" height="102" src="https://www.debugpoint.com/wp-content/uploads/2014/09/libreoffice_logo_post.png" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/libreoffice_logo_post.png 484w, https://www.debugpoint.com/wp-content/uploads/2014/09/libreoffice_logo_post-300x153.png 300w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Writing a Macro in LibreOffice Calc &#8211; Getting...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/writing-a-macro-in-libreoffice-calc-getting-started/">
							Writing a Macro in LibreOffice Calc &#8211; Getting...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/remove-snap-ubuntu/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/04/snapstop-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/04/snapstop-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2022/04/snapstop-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Remove Snap Packages in Ubuntu Linux</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/remove-snap-ubuntu/">
							How to Remove Snap Packages in Ubuntu Linux						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/export-or-save-as-pdf-a-specific-range-in-libreoffice-calc-sheets-using-macro/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Export or Save As PDF A Specific Range...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/export-or-save-as-pdf-a-specific-range-in-libreoffice-calc-sheets-using-macro/">
							Export or Save As PDF A Specific Range...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/upgrade-pop-os-21-04-from-20-10/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Upgrade to Pop OS 21.04 from...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/upgrade-pop-os-21-04-from-20-10/">
							How to Upgrade to Pop OS 21.04 from...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/working-with-dialog-controls-in-libreoffice-calc-using-macro-part-1/">
							<div class="bb-media-placeholder" style="padding-bottom:51%;"><img width="200" height="102" src="https://www.debugpoint.com/wp-content/uploads/2015/01/LO-3d-Header.png" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2015/01/LO-3d-Header.png 487w, https://www.debugpoint.com/wp-content/uploads/2015/01/LO-3d-Header-300x153.png 300w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Working with Dialog Controls in LibreOffice Calc using...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/working-with-dialog-controls-in-libreoffice-calc-using-macro-part-1/">
							Working with Dialog Controls in LibreOffice Calc using...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/failed-to-start-lightdm/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Fix &#8211; Failed to Start Light...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/failed-to-start-lightdm/">
							How to Fix &#8211; Failed to Start Light...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/end-of-elementary-os/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/04/elementaryend-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/04/elementaryend-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2022/04/elementaryend-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Is this the End of the road for...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/end-of-elementary-os/">
							Is this the End of the road for...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/kde-plasma-overview-like-gnome/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2021/11/newoverhead1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="New Effect in Plasma" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/11/newoverhead1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2021/11/newoverhead1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">KDE Plasma Introduces GNOME-like Overview. Is it Good?</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/kde-plasma-overview-like-gnome/">
							KDE Plasma Introduces GNOME-like Overview. Is it Good?						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/libreoffice-like-microsoft-office/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Make LibreOffice Look Like Microsoft Office</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/libreoffice-like-microsoft-office/">
							How to Make LibreOffice Look Like Microsoft Office						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/string-processing-in-libreoffice-calc-macro-with-examples/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">String Processing in LibreOffice Calc Macro with Examples</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/string-processing-in-libreoffice-calc-macro-with-examples/">
							String Processing in LibreOffice Calc Macro with Examples						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/xfce-arch-linux-install-4-16/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Install Xfce Desktop in Arch Linux...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/xfce-arch-linux-install-4-16/">
							How to Install Xfce Desktop in Arch Linux...						</a>
					</h3>
				</li>
					</ul>
	</div>
	
					<div class="row">
				<div class="col-md-4 mb-md">
					<section id="text-77" class="widget widget_text">			<div class="textwidget"><p><a href="https://www.debugpoint.com">DebugPoint.com</a> is a portal covering Technology, Software News and stuff that matters. Heavily slant towards Linux and Open Source.</p>
<p>All applications are registered trademarks of their respective owners. Icons and Logos are used for information purposes, and credit is provided at the end of corresponding articles.</p>
<p>This site serves Ads by a third party that uses cookies and serves ads based on user browsing patterns.</p>
<p>Ideas and opinions expressed here are owned by the author and don&#8217;t necessarily reflect those of other people or organizations.</p>
<p>Linux is a registered trademark of Linus Torvalds.</p>
</div>
		</section>				</div>
				<div class="col-md-4 mb-md">
					<section id="nav_menu-3" class="widget widget_nav_menu"><h4 class="widget-title">Stay in touch</h4><div class="menu-social_links-container"><ul id="menu-social_links-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-832"><a href="http://www.debugpoint.com/feed">RSS</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10578"><a href="https://t.me/debugpoint">Telegram Channel</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10577"><a href="https://news.google.com/publications/CAAqBwgKMOCfmgsw-qmyAw">Google News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-831"><a href="https://twitter.com/DebugPoint">Twitter</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-833"><a href="https://www.youtube.com/c/Debugpoint">YouTube</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-829"><a href="http://www.facebook.com/DebugPoint">Facebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-830"><a href="https://floss.social/@debugpoint">Mastodon</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10579"><a href="https://www.reddit.com/r/debugpoint/">r/debugpoint</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10580"><a href="http://contact@debugpoint.com">Email</a></li>
</ul></div></section>				</div>
				<div class="col-md-4 mb-md">
					<section id="blog_subscription-5" class="widget widget_blog_subscription jetpack_subscription_widget"><h4 class="widget-title">Subscribe to us via Email</h4>
			<div class="wp-block-jetpack-subscriptions__container">
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-5">
									<div id="subscribe-text"><p>Enter your email address to subscribe to debugpoint.com and receive notifications of new posts by email.</p>
</div>
																			<p id="subscribe-email">
						<label id="jetpack-subscribe-label"
							class="screen-reader-text"
							for="subscribe-field-blog_subscription-5">
							Email Address						</label>
						<input type="email" name="email" required="required"
																					value=""
							id="subscribe-field-blog_subscription-5"
							placeholder="Email Address"
						/>
					</p>

					<p id="subscribe-submit"
											>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="source" value="https://www.debugpoint.com/install-ffmpeg-ubuntu/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="subscribe-blog-blog_subscription-5"/>
												<button type="submit"
															class="wp-block-button__link"
																					name="jetpack_subscriptions_widget"
						>
							Subscribe						</button>
					</p>
							</form>
						</div>
			
</section><section id="custom_html-47" class="widget_text widget widget_custom_html"><h4 class="widget-title">Other Projects</h4><div class="textwidget custom-html-widget"><ul>
	<li><a href="https://debugpointnews.com">debugpointnews.com</a></li>
</ul></div></section>				</div>
			</div>
			</div>
</div>
<div class="footer-bottom">
	
	<div class="container">

					<div class="footer-nav">
				<nav>
					<ul id="menu-about_menu" class=""><li id="menu-item-3701" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3701"><a href="https://www.debugpoint.com/about/">About</a></li>
<li id="menu-item-3702" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3702"><a href="https://www.debugpoint.com/content-policy/">Content Policy</a></li>
<li id="menu-item-3703" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3703"><a href="https://www.debugpoint.com/contact-debugpoint/">Contact</a></li>
</ul>				</nav>
			</div>
		
		
		<div class="copy-right">&copy;
			2022 DebugPoint.com All Rights Reserved | Created with ❤ in India 🇮🇳.		</div>

	</div>
</div>				</footer>
			
        <span id="go-top" class="go-top"><i class="bb-icon bb-ui-icon-arrow-up"></i></span>
		</div>

		<div class="light-modal-bg"></div>
<!-- Modal content -->
<div id="sign-in" class="light-modal sign-in authentication">
	<a href="#" class="modal-close"><i class="bb-icon bb-ui-icon-close"></i></a>
	<div class="modal-body wrapper">
		<div class="content-wrapper">
			<header class="content-header">
									<h3 class="title">log in</h3>
				
							</header>
			<div class="content-body">
									<div class="clearfix"></div>
				
				<p class="status-msg bb-txt-msg"></p>

				<form id="boombox-login" class="ajax-auth" action="login" method="post">
					<input type="hidden" id="security" name="security" value="e671c74dbe" /><input type="hidden" name="_wp_http_referer" value="/install-ffmpeg-ubuntu/" />					<div class="input-field">
						<input type="text" name="useremail" class="required" placeholder="Your username or e-mail">
					</div>
					<div class="input-field">
						<input type="password" name="password" class="required" placeholder="Your password">
					</div>

					
					
													<div class="input-field captcha-container loading">
								<div class="form-captcha">
									<img src="" alt="Captcha!" class="captcha">
									<a href="#refresh-captcha" class="auth-refresh-captcha refresh-captcha"></a>
								</div>
								<input type="text" class="required bb-captcha-field" name="captcha-code"
									   placeholder="Enter captcha">
							</div>
											
					<div class="input-field">
						<button class="bb-btn" type="submit">log in</button>
					</div>
					<div class="input-field row-forgot-password">
						<a class="forgot-password-link js-authentication" href="#forgot-password">Forgot password?</a>
					</div>
				</form>
							</div>
					</div>
	</div>
</div>

<!-- Modal content -->
<div id="forgot-password" class="light-modal authentication">
	<a href="#" class="modal-close"><i class="bb-icon bb-ui-icon-close"></i></a>
	<div class="modal-body wrapper">
		<div class="content-wrapper">
			<header class="content-header">
									<h3 class="title">forgot password</h3>
				
							</header>
			<div class="content-body">
				<p class="status-msg bb-txt-msg"></p>
				<form id="boombox_forgot_password" class="ajax-auth" action="forgot_password" method="post">
					<input type="hidden" id="forgotsecurity" name="forgotsecurity" value="a69fdaec68" /><input type="hidden" name="_wp_http_referer" value="/install-ffmpeg-ubuntu/" />					<div class="input-field">
						<input type="text" name="userlogin" class="required"
						       placeholder="Your username or e-mail">
					</div>
					<div class="input-field">
						<button class="bb-btn" type="submit">reset</button>
					</div>
				</form>
			</div>
			<div class="content-footer">
				<div class="bottom">
					<div class="text">Back to </div>
					<a class="bb-btn bb-btn-default js-authentication"
					   href="#sign-in">log in</a>
				</div>
			</div>
		</div>
	</div>
</div>


<div id='wpd-bubble-wrapper'><span id='wpd-bubble-all-comments-count' style='display:none;' title='0'>0</span><div id='wpd-bubble-count'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-count-first' d='M20 2H4c-1.1 0-1.99.9-1.99 2L2 22l4-4h14c1.1 0 2-.9 2-2V4c0-1.1-.9-2-2-2zm-2 12H6v-2h12v2zm0-3H6V9h12v2zm0-3H6V6h12v2z'/><path class='wpd-bubble-count-second' d='M0 0h24v24H0z' /></svg><span class='wpd-new-comments-count'>0</span></div><div id='wpd-bubble'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-plus-first' d='M19 13h-6v6h-2v-6H5v-2h6V5h2v6h6v2z'/><path class='wpd-bubble-plus-second' d='M0 0h24v24H0z' /></svg><div id='wpd-bubble-add-message'>Would love your thoughts, please comment.<span id='wpd-bubble-add-message-close'><a href='#'>x</a></span></div></div><div id='wpd-bubble-notification'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-notification-first' d='M20 2H4c-1.1 0-1.99.9-1.99 2L2 22l4-4h14c1.1 0 2-.9 2-2V4c0-1.1-.9-2-2-2zm-2 12H6v-2h12v2zm0-3H6V9h12v2zm0-3H6V6h12v2z'/><path class='wpd-bubble-notification-second' d='M0 0h24v24H0z' /></svg><div id='wpd-bubble-notification-message'><div id='wpd-bubble-author'><div><span id='wpd-bubble-author-avatar'></span><span id='wpd-bubble-author-name'></span><span id='wpd-bubble-comment-date'>(<span class='wpd-bubble-spans'></span>)</span></div><span id='wpd-bubble-comment-close'><a href='#'>x</a></span></div><div id='wpd-bubble-comment'><span id='wpd-bubble-comment-text'></span><span id='wpd-bubble-comment-reply-link'>| <a href='#'>Reply</a></span></div></div></div></div><div id='wpd-editor-source-code-wrapper-bg'></div><div id='wpd-editor-source-code-wrapper'><textarea id='wpd-editor-source-code'></textarea><button id='wpd-insert-source-code'>Insert</button><input type='hidden' id='wpd-editor-uid' /></div><script type='text/javascript' src='https://www.debugpoint.com/wp-content/plugins/sg-cachepress/assets/js/lazysizes.min.js?ver=7.2.5' id='siteground-optimizer-lazy-sizes-js-js' defer></script>
<script type='text/javascript' id='wpdiscuz-combo-js-js-extra'>
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_comment_edit_not_possible":"Sorry, this comment is no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_spoiler_title":"Spoiler Title","wc_cannot_rate_again":"You cannot rate again","wc_not_allowed_to_rate":"You're not allowed to rate here","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":"","commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"30","liveUpdateGuests":"0","wordpressThreadCommentsDepth":"10","wordpressIsPaginate":"","commentTextMaxLength":"0","replyTextMaxLength":"0","commentTextMinLength":"1","replyTextMinLength":"1","storeCommenterData":"100000","socialLoginAgreementCheckbox":"1","enableFbLogin":"0","fbUseOAuth2":"0","enableFbShare":"0","facebookAppID":"","facebookUseOAuth2":"0","enableGoogleLogin":"0","googleClientID":"","googleClientSecret":"","cookiehash":"e7741ca40378847c56d9aca08aad2046","isLoadOnlyParentComments":"0","scrollToComment":"1","commentFormView":"collapsed","enableDropAnimation":"0","isNativeAjaxEnabled":"1","enableBubble":"1","bubbleLiveUpdate":"0","bubbleHintTimeout":"45","bubbleHintHideTimeout":"10","cookieHideBubbleHint":"wpdiscuz_hide_bubble_hint","bubbleShowNewCommentMessage":"1","bubbleLocation":"right_corner","firstLoadWithAjax":"1","wc_copied_to_clipboard":"Copied to clipboard!","inlineFeedbackAttractionType":"blink","loadRichEditor":"1","wpDiscuzReCaptchaSK":"","wpDiscuzReCaptchaTheme":"light","wpDiscuzReCaptchaVersion":"2.0","wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","wpDiscuzIsShowOnSubscribeForm":"0","wmuEnabled":"1","wmuInput":"wmu_files","wmuMaxFileCount":"1","wmuMaxFileSize":"2097152","wmuPostMaxSize":"268435456","wmuIsLightbox":"1","wmuMimeTypes":{"jpg":"image\/jpeg","jpeg":"image\/jpeg","jpe":"image\/jpeg","gif":"image\/gif","png":"image\/png","bmp":"image\/bmp","tiff":"image\/tiff","tif":"image\/tiff","ico":"image\/x-icon"},"wmuPhraseConfirmDelete":"Are you sure you want to delete this attachment?","wmuPhraseNotAllowedFile":"Not allowed file type","wmuPhraseMaxFileCount":"Maximum number of uploaded files is 1","wmuPhraseMaxFileSize":"Maximum upload file size is 2MB","wmuPhrasePostMaxSize":"Maximum post size is 256MB","wmuPhraseDoingUpload":"Uploading in progress! Please wait.","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgPostIdNotExists":"Post ID not exists","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuKeyImages":"images","wmuSingleImageWidth":"auto","wmuSingleImageHeight":"200","version":"7.5","wc_post_id":"9869","isCookiesEnabled":"1","loadLastCommentId":"0","dataFilterCallbacks":[],"phraseFilters":[],"scrollSize":"32","is_email_field_required":"1","url":"https:\/\/www.debugpoint.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/www.debugpoint.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","bubbleUpdateUrl":"https:\/\/www.debugpoint.com\/wp-json\/wpdiscuz\/v1\/update","restNonce":"bce516a2de","validateNonceForGuests":""};
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Are you sure you want to delete this comment?","msgConfirmCancelSubscription":"Are you sure you want to cancel this subscription?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?","additionalTab":"0"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='wpdiscuz-combo-js-js-before'>
        var wpdiscuzEditorOptions = {
        modules: {
        toolbar: "",
        counter: {
        uniqueID: "",
        commentmaxcount : 0,
        replymaxcount : 0,
        commentmincount : 1,
        replymincount : 1,
        },
                },
        wc_be_the_first_text: "Be the First to Comment!",
        wc_comment_join_text: "Join the discussion",
        theme: 'snow',
        debug: 'error'
        };
        
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-combo.min.js?ver=7.5' id='wpdiscuz-combo-js-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/www.debugpoint.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-includes/js/comment-reply.min.js?ver=ace0b72f8510807974c54019f37d3bc2' id='comment-reply-js' defer></script>
<script type='text/javascript' id='boombox-scripts-min-js-extra'>
/* <![CDATA[ */
var boombox_global_vars = {"boombox_gif_event":"click","single_post_animated_hyena_gifs_excluded_js_selectors":[],"videoOptions":{"playerControls":"mute","autoPlay":"scroll","sound":"muted","clickEvent":"mute_unmute","loop":1}};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-content/themes/boombox/js/scripts.min.js?ver=2.8.4' id='boombox-scripts-min-js' defer></script>
<script type='text/javascript' id='boombox-ajax-js-extra'>
/* <![CDATA[ */
var boombox_ajax_params = {"ajax_url":"https:\/\/www.debugpoint.com\/wp-admin\/admin-ajax.php","track_view":"1","track_view_request_cache":"1"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-content/themes/boombox/includes/rate-and-vote-restrictions/js/ajax.min.js?ver=2.8.4' id='boombox-ajax-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" defer data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1660756923' id='akismet-frontend-js'></script>
	<script src='https://stats.wp.com/e-202245.js' defer></script>
	<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'178518717',post:'9869',tz:'5.5',srv:'www.debugpoint.com',j:'1:11.5.1'} ]);
		_stq.push([ 'clickTrackerInit', '178518717', '9869' ]);
	</script>	</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1668138107 -->