<!DOCTYPE HTML>
<html lang="en-US">
	<head><meta charset="UTF-8"><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
		
		<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
				<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
	<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		(function( $ ) {

			var themeModeStylesheetURL = 'https://www.debugpoint.com/wp-content/themes/boombox/css/night-mode.min.css';
			var getCookie = function( cname ) {
				var name = cname + "=";
				var decodedCookie = decodeURIComponent( document.cookie );
				var ca = decodedCookie.split( ';' );
				for ( var i = 0; i < ca.length; i++ ) {
					var c = ca[i];
					while ( c.charAt( 0 ) == ' ' ) {
						c = c.substring( 1 );
					}
					if ( c.indexOf( name ) == 0 ) {
						return c.substring( name.length, c.length );
					}
				}
				return "";
			};
			var setCookie = function( cname, cvalue, exdays ) {
				var d = new Date();
				d.setTime( d.getTime() + (exdays * 24 * 60 * 60 * 1000) );
				var expires = "expires=" + d.toUTCString();
				document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
			};
			var delete_cookie = function( cname ) {
				setCookie( cname, null, 0 );
			};
			var appendThemeModeLink = function() {
				var link = document.createElement( 'link' );
				var targetNode = document.getElementById( 'boombox-primary-style-inline-css' );
				link.rel = 'stylesheet';
				link.id = 'boombox-theme-mode-css';
				link.href = themeModeStylesheetURL;
				link.media = 'all';

				targetNode.parentNode.insertBefore( link, targetNode.nextSibling );
			};

			document.addEventListener( 'DOMContentLoaded', function() {
				var switchers = document.querySelectorAll( '.bb-mode-switcher .bb-mode-toggle' );

				for ( var i = 0; i < switchers.length; i++ ) {
					switchers[i].addEventListener( 'click', function(e) {
					    e.preventDefault();
						var stylesheet = document.getElementById( 'boombox-theme-mode-css' );
						if ( !!getCookie( 'boombox-theme-mode' ) ) {
							if ( stylesheet ) {
								stylesheet.setAttribute( 'disabled', 'disabled' );
							}
                            document.body.classList.remove("boombox-mode-on");
							delete_cookie( 'boombox-theme-mode' );
						} else {
							if ( stylesheet ) {
								stylesheet.removeAttribute( 'disabled' );
							} else {
								appendThemeModeLink();
							}
                            document.body.classList.add("boombox-mode-on");
							setCookie( 'boombox-theme-mode', 1, 365 );
						}
					} );
				}

                if ( !!getCookie( 'boombox-theme-mode' ) ) {
                    document.body.classList.add("boombox-mode-on");
                }
			} );

			if ( !!getCookie( 'boombox-theme-mode' ) ) {

				var appendInterval = setInterval( function() {
					if ( document.getElementById( 'boombox-primary-style-inline-css' ) ) {
						clearInterval( appendInterval );
						appendThemeModeLink();
					}
				}, 25 );
			}

		})();
	</script>
	<!-- This site is optimized with the Yoast SEO plugin v19.13 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Debugging LibreOffice Basic Macro using Breakpoint and Watch</title>
	<meta name="description" content="A tutorial on debugging a LibreOffice Basic macro using breakpoint and watching in LibreOffice&#039;s built-in macro editor." />
	<link rel="canonical" href="https://www.debugpoint.com/debugging-libreoffice-macro-basic-using-breakpoint-and-watch/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Debugging LibreOffice Basic Macro using Breakpoint and Watch" />
	<meta property="og:description" content="A tutorial on debugging a LibreOffice Basic macro using breakpoint and watching in LibreOffice&#039;s built-in macro editor." />
	<meta property="og:url" content="https://www.debugpoint.com/debugging-libreoffice-macro-basic-using-breakpoint-and-watch/" />
	<meta property="og:site_name" content="DebugPoint.com" />
	<meta property="article:publisher" content="http://www.facebook.com/DebugPoint" />
	<meta property="article:published_time" content="2022-12-21T05:31:00+00:00" />
	<meta property="article:modified_time" content="2022-12-21T08:41:57+00:00" />
	<meta property="og:image" content="https://www.debugpoint.com/wp-content/uploads/2014/09/debugnew1lo.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="675" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Arindam" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@_arindam" />
	<meta name="twitter:site" content="@_arindam" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />

<link rel="alternate" type="application/rss+xml" title="DebugPoint.com &raquo; Feed" href="https://www.debugpoint.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="DebugPoint.com &raquo; Comments Feed" href="https://www.debugpoint.com/comments/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css' href='https://www.debugpoint.com/wp-includes/css/dist/block-library/style.min.css?ver=5713576bf9cd4aaa3daad2ecf79db42e' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://www.debugpoint.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.17' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://www.debugpoint.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5713576bf9cd4aaa3daad2ecf79db42e' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://www.debugpoint.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link data-minify="1" rel='stylesheet' id='same-category-posts-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/plugins/same-category-posts/same-category-posts.css?ver=1660756792' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='boombox-styles-min-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/themes/boombox/js/plugins/plugins.min.css?ver=1660486031' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='boombox-icomoon-style-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/themes/boombox/fonts/icon-fonts/icomoon/icons.min.css?ver=1660486031' type='text/css' media='all' />
<link data-minify="1" rel='stylesheet' id='boombox-primary-style-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/themes/boombox/css/style.min.css?ver=1660486031' type='text/css' media='all' />
<style id='boombox-primary-style-inline-css' type='text/css'>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</style>
<link data-minify="1" rel='stylesheet' id='jetpack_css-css' href='https://www.debugpoint.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack.css?ver=1660756792' type='text/css' media='all' />
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>

<!-- Google Analytics snippet added by Site Kit -->
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-53016023-1' id='google_gtagjs-js' async></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["www.debugpoint.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-53016023-1", {"anonymize_ip":true});
gtag("config", "G-0P8HHR1JXV");
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<link rel="https://api.w.org/" href="https://www.debugpoint.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.debugpoint.com/wp-json/wp/v2/posts/483" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.debugpoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.debugpoint.com/wp-includes/wlwmanifest.xml" />

<link rel='shortlink' href='https://www.debugpoint.com/?p=483' />
<link rel="alternate" type="application/json+oembed" href="https://www.debugpoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.debugpoint.com%2Fdebugging-libreoffice-macro-basic-using-breakpoint-and-watch%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.debugpoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.debugpoint.com%2Fdebugging-libreoffice-macro-basic-using-breakpoint-and-watch%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.90.0" /><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.debugpoint.com/?wordfence_lh=1&hid=8DB7B0D6B770E59BD2611EC95E5551E3');
</script>	<style>img#wpstats{display:none}</style>
		
<link rel="preload" as="font" href="https://www.debugpoint.com/wp-content/themes/boombox/fonts/icon-fonts/icomoon/fonts/bb-icomoon.ttf" crossorigin>
<link rel="preload" as="font" href="https://www.debugpoint.com/wp-content/themes/boombox/scss/icon-fonts/fonts/ui-icomoon.ttf" crossorigin>
<link rel="preload" as="font" href="https://www.debugpoint.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/webfonts/fa-regular-400.woff2" crossorigin>
<link rel="preload" as="font" href="https://www.debugpoint.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/webfonts/fa-solid-900.woff2" crossorigin>
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="amphtml" href="https://www.debugpoint.com/debugging-libreoffice-macro-basic-using-breakpoint-and-watch/?amp=1">
<!-- Google AdSense snippet added by Site Kit -->
<script type="rocketlazyloadscript" async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-1235852655833346&amp;host=ca-host-pub-2644536267352236" crossorigin="anonymous" data-rocket-type="text/javascript"></script>

<!-- End Google AdSense snippet added by Site Kit -->
<link rel="preload" href="/fonts/Nunito-Regular.woff" as="font" type="font/woff2" crossorigin><link rel="icon" href="https://www.debugpoint.com/wp-content/uploads/2021/07/cropped-drawing2-site-icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.debugpoint.com/wp-content/uploads/2021/07/cropped-drawing2-site-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.debugpoint.com/wp-content/uploads/2021/07/cropped-drawing2-site-icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.debugpoint.com/wp-content/uploads/2021/07/cropped-drawing2-site-icon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			pre {
    background: #edeff1;
    padding: 0.5em;
    border-left: 4px solid green;
	font-size: 14px;
	/*box-shadow: 5px 5px 5px 0px rgba(0, 0, 0, 0.2), 0 5px 10px 0 rgba(0, 0, 0, 0.19);*/
}

.mywarn1 {
    background-color: lightgrey;
    border-left: 4px solid red;
    padding: 0.5em;
}

.mynote1 {
    background-color: #ffffcc;
    border-left: 4px solid #ffeb3b;
    padding: 0.5em;
}


.cooldiv1 {
    background: linear-gradient(90deg, rgba(28,113,216,1) 0%, rgba(48,200,119,1) 100%);
    padding: 4px 5px 4px 10px;
    font-size: 100%;
    color: white;
	border-radius: 3px;
}

.cooldiv2
{
    background: linear-gradient(90deg, #4275b2 0%, #4eaa88 100%);
    border: none;
    font-size: 100%;
    margin-bottom: 0px;
    color: white;
}

.cooldiv-warning {
    background: linear-gradient(90deg, rgb(205, 32, 31) 0%, rgb(247, 119, 55) 100%);
    padding: 4px 5px 4px 10px;
    font-size: 100%;
    color: white;
    border-radius: 3px;
}

.cooldivold
{
    background: linear-gradient(90deg, #200122 0%, #6f0000 100%);
    border: none;
    font-size: 100%;
    margin-bottom: 0px;
    color: white;
}

.bb-ui-icon-search {color:#b60400;}

/**Px-Lab Support: make the content font weight 300 **/
body, html {
    font-weight: 400;
	line-height:1.6;
}

.widget-title {
	color:#b60400;
}

/* Zoom-n-rotate Container */
.branding img {
  transition: transform .5s ease-in-out;
}

/* The Transformation */
.branding:hover img {
  transform: scale(1.2) rotate(2deg);
}

.s-post-content img {
	box-shadow: 5px 5px 5px 0px rgba(0, 0, 0, 0.2), 0 5px 10px 0 rgba(0, 0, 0, 0.19);
	
}

/* announcement div */

.ann-div-1 {
    border: 1px solid;
    padding: 12px 1px 1px 15px;
    background-color: aliceblue;
    border-color: cadetblue;
    border-radius: 5px;
}

.wp-block-image figcaption {
	color: grey;
	
}

.bb-post-single .s-post-content p {
    margin-top: 1rem;
    line-height: 1.5em;
    font-size: 16px;
}

.bb-post-single .s-post-content li {
    line-height: 1.5em;
    font-size: 16px;
 
}

.bb-post-single .s-post-content h2 {
    font-size: 1.5em;
 
}

.bb-post-single .s-post-content h3 {
    font-size: 1.17em; 
}

.container {width:1600px;}

@font-face {
font-family: 'Nunito';
src: url('https://www.debugpoint.com/fonts/Nunito-Regular.woff') format('woff');
font-weight: normal;
font-style: normal;
	font-display:swap;
}

body, html {
font-family:"Nunito";
}


 
.dp-home-main-block {
   border-style: solid;
    border-color: lightgray;
    border-width: 1px;
    border-radius: 10px;
	background-color: white;
	    margin-top: 10px;
    padding: 20px 5px 5px 15px;
  }  
  
  .dp-home-main-block-sub {
    max-width: 1700px;
    margin-left: auto;
    margin-right: auto;
    padding: 20px;
}

.dp-home-main-block h2 {
    font-weight: 600;
    font-size: 20px;
    padding: 1PX 1PX 12px 2px;
    border-bottom: 1px solid #dadce0;
	
}
  
.dp-home-main-block li {
    padding: 0px 0px 5px 0px;
}

.dp-gnews-link {
margin-bottom: 16px;
margin-left: auto;
margin-right: auto;
max-width: 750px;
padding-left: 10px;
padding-right: 10px;
background-color: #ecfbf1;
font-size: 1.1em;
line-height: 1.5em;
border-radius: 10px;
border-color: #d7e6d7;
border-width: 0.1px;
}

.dp-telegram-link {
margin-bottom: 16px;
margin-left: auto;
margin-right: auto;
max-width: 750px;
padding-left: 10px;
padding-right: 10px;
background-color: aliceblue;
font-size: 1.1em;
line-height: 1.5em;
border-radius: 10px;
border-color: #bfd5fd;
border-width: 0.1px;
}

.bb-next-prev-pagination.pg-lg .page-link, .bb-next-prev-pagination.pg-md .page-link {color: whitesmoke;}


		</style>
			</head>

	<body class="post-template-default single single-post postid-483 single-format-standard wp-custom-logo boombox-theme-light two-sidebar sidebar-1_3-1_4 right-sidebar badge-face-text badges-outside-left bb-cards-view material-cards">


		
	<div id="mobile-nav-bg"></div>
	<div id="mobile-navigation" class="bb-mobile-navigation">
		<button id="menu-close" class="close">
			<i class="bb-icon bb-ui-icon-close"></i>
		</button>
		<div class="holder">
			<div class="more-menu">
				<div class="more-menu-header">
									</div>
					<nav class="main-navigation">
		<ul id="menu-social_links" class=""><li id="menu-item-832" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-832 menu-item-icon"><a href="http://www.debugpoint.com/feed"><i class="bb-icon bb-icon-rss"></i>RSS</a></li>
<li id="menu-item-10578" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10578 menu-item-icon"><a href="https://t.me/debugpoint"><i class="bb-icon bb-icon-comments"></i>Telegram Channel</a></li>
<li id="menu-item-10577" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10577 menu-item-icon"><a href="https://news.google.com/publications/CAAqBwgKMOCfmgsw-qmyAw"><i class="bb-icon bb-icon-newspaper"></i>Google News</a></li>
<li id="menu-item-831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-831 menu-item-icon"><a href="https://twitter.com/DebugPoint"><i class="bb-icon bb-icon-at"></i>Twitter</a></li>
<li id="menu-item-830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-830 menu-item-icon"><a href="https://floss.social/@debugpoint"><i class="bb-icon bb-icon-at"></i>Mastodon</a></li>
<li id="menu-item-833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-833 menu-item-icon"><a href="https://www.youtube.com/c/Debugpoint"><i class="bb-icon bb-icon-youtube"></i>YouTube</a></li>
<li id="menu-item-829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-829 menu-item-icon"><a href="http://www.facebook.com/DebugPoint"><i class="bb-icon bb-icon-facebook-square"></i>Facebook</a></li>
<li id="menu-item-10579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10579 menu-item-icon"><a href="https://www.reddit.com/r/debugpoint/"><i class="bb-icon bb-icon-zombify_personality_quiz"></i>r/debugpoint</a></li>
<li id="menu-item-10580" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10580 menu-item-icon"><a href="http://contact@debugpoint.com"><i class="bb-icon bb-icon-envelope"></i>Email</a></li>
</ul>	</nav>
		<nav class="main-navigation">
		<ul id="menu-top_menu_generic" class=""><li id="menu-item-10188" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10188"><a href="#">Guide &#038; Review</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-930" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-930 menu-item-icon"><a href="https://www.debugpoint.com/category/tutorials/"><i class="bb-icon bb-icon-book2"></i>All Tutorial(s)</a></li>
	<li id="menu-item-10189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10189"><a href="https://www.debugpoint.com/tag/linux-distro-review">Linux Distro Review</a></li>
	<li id="menu-item-10190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10190"><a href="https://www.debugpoint.com/category/review/">Complete Review Index</a></li>
</ul>
</li>
<li id="menu-item-927" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-927 menu-item-icon"><a href="https://www.debugpoint.com/category/apps/"><i class="bb-icon bb-icon-app-store"></i>App</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-3559" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3559"><a href="https://www.debugpoint.com/category/top-list/">Top List Index</a></li>
	<li id="menu-item-10191" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10191"><a href="https://www.debugpoint.com/tag/top-10-list">Top 10 List</a></li>
	<li id="menu-item-10192" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10192"><a href="https://www.debugpoint.com/tag/ubuntu-apps">Ubuntu Apps</a></li>
	<li id="menu-item-10194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10194"><a href="https://www.debugpoint.com/tag/gnome-apps">GNOME Apps</a></li>
	<li id="menu-item-10193" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10193"><a href="https://www.debugpoint.com/tag/kde-apps">KDE Apps</a></li>
	<li id="menu-item-480" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-480"><a href="https://www.debugpoint.com/category/libreoffice/">LibreOffice</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li id="menu-item-12385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12385 menu-item-icon"><a href="https://www.libreofficehelp.com"><i class="bb-icon bb-icon-chart-bar"></i>Exclusive LibreOffice Tutorials<span class="label new">New</span></a></li>
		<li id="menu-item-481" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-481"><a href="https://www.debugpoint.com/category/libreoffice/libreoffice-calc/">Calc</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-3310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3310 menu-item-icon"><a href="https://www.debugpoint.com/category/desktop-environment/themes/"><i class="bb-icon bb-icon-paint-brush"></i>Theme</a></li>
<li id="menu-item-5024" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5024 menu-item-icon"><a href="https://www.debugpoint.com/category/distributions/"><i class="bb-icon bb-icon-tech1"></i>Distro</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-10111" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10111"><a href="#">Upcoming</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li id="menu-item-10117" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10117"><a href="https://www.debugpoint.com/tag/elementary-os-7/">elementary OS 7 Horus</a></li>
	</ul>
</li>
	<li id="menu-item-10116" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10116"><a href="#">Current</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li id="menu-item-10925" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10925"><a href="https://www.debugpoint.com/tag/fedora-37">Fedora 37</a></li>
		<li id="menu-item-10926" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10926"><a href="https://www.debugpoint.com/tag/ubuntu-22-10">Ubuntu 22.10 (Kinetic Kudu)</a></li>
		<li id="menu-item-10114" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10114"><a href="https://www.debugpoint.com/tag/linux-mint-21/">Linux Mint 21.0 and 21.1</a></li>
		<li id="menu-item-8040" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8040"><a href="https://www.debugpoint.com/tag/elementary-os-6">elementary OS 6</a></li>
	</ul>
</li>
	<li id="menu-item-8039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8039"><a href="https://www.debugpoint.com/tag/arch-linux">Arch Linux</a></li>
	<li id="menu-item-8684" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8684"><a href="https://www.debugpoint.com/tag/pop-os/">Pop!_OS</a></li>
	<li id="menu-item-8041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8041"><a href="https://www.debugpoint.com/tag/linux-distro-review">Distro Review</a></li>
	<li id="menu-item-8043" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8043"><a href="https://www.debugpoint.com/category/distributions/">View All Distros</a></li>
</ul>
</li>
<li id="menu-item-928" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-928 menu-item-icon"><a href="https://www.debugpoint.com/category/desktop-environment/"><i class="bb-icon bb-icon-tv"></i>DE</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-8037" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8037"><a href="https://debugpointnews.com/gnome-43-alpha/">GNOME 43</a></li>
	<li id="menu-item-8036" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8036"><a href="https://www.debugpoint.com/tag/kde-plasma-5-26">KDE Plasma 5.26</a></li>
	<li id="menu-item-8038" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8038"><a href="https://www.debugpoint.com/tag/xfce-4-18">Xfce 4.18</a></li>
	<li id="menu-item-8683" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8683"><a href="https://www.debugpoint.com/tag/lxqt/">LXQt</a></li>
	<li id="menu-item-8042" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8042"><a href="https://www.debugpoint.com/category/desktop-environment/">View All Desktop Env</a></li>
</ul>
</li>
<li id="menu-item-9343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9343 menu-item-icon"><a href="https://debugpointnews.com"><i class="bb-icon bb-icon-newspaper2"></i>News<span class="label new">New</span></a></li>
<li id="menu-item-4911" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-4911 menu-item-icon"><a href="https://www.debugpoint.com/category/development/"><i class="bb-icon bb-icon-code"></i>Dev</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-10113" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10113"><a href="https://www.debugpoint.com/tag/linux-kernel-6-1/">Linux Kernel 6.1</a></li>
	<li id="menu-item-1464" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1464"><a href="https://www.debugpoint.com/libreoffice-basic-macro-tutorial-index/">LibreOffice Macro</a></li>
</ul>
</li>
<li id="menu-item-8142" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-8142"><a href="#">More</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li id="menu-item-8143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8143 menu-item-icon"><a href="https://www.debugpoint.com/category/opinion/"><i class="bb-icon bb-icon-bullhorn"></i>Editorial and Opinion<span class="label hot">Hot</span></a></li>
	<li id="menu-item-929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-929 menu-item-icon"><a href="https://www.debugpoint.com/category/hardware/"><i class="bb-icon bb-icon-cogs"></i>Hardware</a></li>
</ul>
</li>
</ul>	</nav>
	
				<div class="more-menu-footer">

					
				</div>
			</div>

		</div>
	</div>
	
		<div id="page-wrapper" class="page-wrapper">

			
	<header class="bb-show-desktop-header bb-header header-desktop no-bottom top-shadow">

		<div class="bb-sticky bb-sticky-nav sticky-smart">
			<div class="top-header  medium full-width menu-center bb-sticky-el">
				<div class="container">

					
											<div class="h-component m-1 logo">
<div class="branding">
	<p class="site-title">
		<a href="https://www.debugpoint.com/">

								<img width="370" height="33" class="site-logo " src="https://www.debugpoint.com/wp-content/uploads/2021/12/dp-logo-2021-base2-xmas.png" alt="DebugPoint.com" srcset="https://www.debugpoint.com/wp-content/uploads/2021/12/dp-logo-2021-base3-xmas2021-retina.png 2x,https://www.debugpoint.com/wp-content/uploads/2021/12/dp-logo-2021-base2-xmas.png 1x" />
						</a>
	</p>

	</div></div>
											<div class="h-component m-2">

															<div class="bb-header-navigation header-item">
										<nav class="main-navigation">
		<ul id="menu-top_menu_generic-1" class=""><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10188"><a href="#">Guide &#038; Review</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-930 menu-item-icon"><a href="https://www.debugpoint.com/category/tutorials/"><i class="bb-icon bb-icon-book2"></i>All Tutorial(s)</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10189"><a href="https://www.debugpoint.com/tag/linux-distro-review">Linux Distro Review</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10190"><a href="https://www.debugpoint.com/category/review/">Complete Review Index</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-927 menu-item-icon"><a href="https://www.debugpoint.com/category/apps/"><i class="bb-icon bb-icon-app-store"></i>App</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3559"><a href="https://www.debugpoint.com/category/top-list/">Top List Index</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10191"><a href="https://www.debugpoint.com/tag/top-10-list">Top 10 List</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10192"><a href="https://www.debugpoint.com/tag/ubuntu-apps">Ubuntu Apps</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10194"><a href="https://www.debugpoint.com/tag/gnome-apps">GNOME Apps</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10193"><a href="https://www.debugpoint.com/tag/kde-apps">KDE Apps</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-480"><a href="https://www.debugpoint.com/category/libreoffice/">LibreOffice</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12385 menu-item-icon"><a href="https://www.libreofficehelp.com"><i class="bb-icon bb-icon-chart-bar"></i>Exclusive LibreOffice Tutorials<span class="label new">New</span></a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-481"><a href="https://www.debugpoint.com/category/libreoffice/libreoffice-calc/">Calc</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3310 menu-item-icon"><a href="https://www.debugpoint.com/category/desktop-environment/themes/"><i class="bb-icon bb-icon-paint-brush"></i>Theme</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5024 menu-item-icon"><a href="https://www.debugpoint.com/category/distributions/"><i class="bb-icon bb-icon-tech1"></i>Distro</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10111"><a href="#">Upcoming</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10117"><a href="https://www.debugpoint.com/tag/elementary-os-7/">elementary OS 7 Horus</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10116"><a href="#">Current</a><span class="dropdown-toggle"></span>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10925"><a href="https://www.debugpoint.com/tag/fedora-37">Fedora 37</a></li>
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10926"><a href="https://www.debugpoint.com/tag/ubuntu-22-10">Ubuntu 22.10 (Kinetic Kudu)</a></li>
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10114"><a href="https://www.debugpoint.com/tag/linux-mint-21/">Linux Mint 21.0 and 21.1</a></li>
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8040"><a href="https://www.debugpoint.com/tag/elementary-os-6">elementary OS 6</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8039"><a href="https://www.debugpoint.com/tag/arch-linux">Arch Linux</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8684"><a href="https://www.debugpoint.com/tag/pop-os/">Pop!_OS</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8041"><a href="https://www.debugpoint.com/tag/linux-distro-review">Distro Review</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8043"><a href="https://www.debugpoint.com/category/distributions/">View All Distros</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-928 menu-item-icon"><a href="https://www.debugpoint.com/category/desktop-environment/"><i class="bb-icon bb-icon-tv"></i>DE</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8037"><a href="https://debugpointnews.com/gnome-43-alpha/">GNOME 43</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8036"><a href="https://www.debugpoint.com/tag/kde-plasma-5-26">KDE Plasma 5.26</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8038"><a href="https://www.debugpoint.com/tag/xfce-4-18">Xfce 4.18</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8683"><a href="https://www.debugpoint.com/tag/lxqt/">LXQt</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8042"><a href="https://www.debugpoint.com/category/desktop-environment/">View All Desktop Env</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9343 menu-item-icon"><a href="https://debugpointnews.com"><i class="bb-icon bb-icon-newspaper2"></i>News<span class="label new">New</span></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-4911 menu-item-icon"><a href="https://www.debugpoint.com/category/development/"><i class="bb-icon bb-icon-code"></i>Dev</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10113"><a href="https://www.debugpoint.com/tag/linux-kernel-6-1/">Linux Kernel 6.1</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1464"><a href="https://www.debugpoint.com/libreoffice-basic-macro-tutorial-index/">LibreOffice Macro</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-8142"><a href="#">More</a><span class="dropdown-toggle"></span>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8143 menu-item-icon"><a href="https://www.debugpoint.com/category/opinion/"><i class="bb-icon bb-icon-bullhorn"></i>Editorial and Opinion<span class="label hot">Hot</span></a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-929 menu-item-icon"><a href="https://www.debugpoint.com/category/hardware/"><i class="bb-icon bb-icon-cogs"></i>Hardware</a></li>
</ul>
</li>
</ul>	</nav>
									</div>
													</div>
					
										<div class="h-component r-1 has-mode-switcher has-search has-burger-icon">
						
<div class="bb-mode-switcher header-item">
	<a href="#" class="bb-mode-toggle bb-header-icon" role="button" rel="nofollow">
		<i class="bb-placeholder bb-icon bb-ui-icon-sun"></i>
		<i class="bb-day-mode-icon bb-icon bb-ui-icon-sun"></i>
		<i class="bb-night-mode-icon bb-icon bb-ui-icon-moon"></i>
	</a>
</div><div class="bb-header-search header-item bb-toggle bb-focus pos-right">
	<a class="form-toggle element-toggle element-focus bb-header-icon" href="#" role="button" data-toggle=".search-dropdown" data-focus=".search-form input">
		<i class="bb-icon bb-ui-icon-search"></i>
	</a>
	<div class="search-dropdown bb-header-dropdown toggle-content">
		<form role="search" method="get" class="search-form form" action="https://www.debugpoint.com/">
			<input type="search" class="pull-left" name="s" value="">
			<button class="search-submit pull-right"
			        type="submit">Search</button>
		</form>
	</div>
</div>

<a id="menu-button"
   class="header-item bb-header-icon menu-button pos-right"
   role="button"
   href="#">
	<i class="bb-ui-icon-burger-menu"></i>
</a>					</div>
					
				</div>

				
			</div>
			</div>
		
	</header>

	<div class="bb-show-mobile-header bb-sticky bb-sticky-nav sticky-classic">	<header class="bb-header header-mobile h-style h-style-left large bb-sticky-el">
		<div class="container header-row">
			<div class="header-row-layout">

				
				<div class="header-col header-c">
					
<div class="branding">
	<p class="site-title">
		<a href="https://www.debugpoint.com/">
								<img width="370" height="33" class="site-logo-mobile " src="https://www.debugpoint.com/wp-content/uploads/2021/12/dp-logo-2021-base2-xmas.png" alt="DebugPoint.com" srcset="https://www.debugpoint.com/wp-content/uploads/2021/12/dp-logo-2021-base3-xmas2021-retina.png 2x,https://www.debugpoint.com/wp-content/uploads/2021/12/dp-logo-2021-base2-xmas.png 1x" />

						</a>
	</p>
</div>				</div>

									<div class="header-col header-r">
						<div class="bb-header-search header-item bb-toggle bb-focus pos-right">
	<a class="form-toggle element-toggle element-focus bb-header-icon" href="#" role="button" data-toggle=".search-dropdown" data-focus=".search-form input">
		<i class="bb-icon bb-ui-icon-search"></i>
	</a>
	<div class="search-dropdown bb-header-dropdown toggle-content">
		<form role="search" method="get" class="search-form form" action="https://www.debugpoint.com/">
			<input type="search" class="pull-left" name="s" value="">
			<button class="search-submit pull-right"
			        type="submit">Search</button>
		</form>
	</div>
</div>

<a id="menu-button"
   class="header-item bb-header-icon menu-button pos-right"
   role="button"
   href="#">
	<i class="bb-ui-icon-burger-menu"></i>
</a>					</div>
				
			</div>
		</div>
	</header>
</div>
			<main id="main" role="main">

				<div class="container single-container s-mt-sm">

		<article id="post-483" class="single post bb-post-single style1 post-483 type-post status-publish format-standard has-post-thumbnail category-calc-macros category-development tag-libreoffice-macro" data-post-id="483" itemscope="" itemtype="http://schema.org/Article">
		<div class="single-top-container bb-mb-el mb-xs">
			<nav class="s-post-breadcrumb bb-breadcrumb clr-style1">	<div class="breadcrumb-inner" role="navigation" aria-label="Breadcrumb">
		<ol itemscope itemtype="http://schema.org/BreadcrumbList">
							<li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">

					<a class="ordinal-item" itemprop="item" href="https://www.debugpoint.com/" >
													<span itemprop="name">Home</span>
											</a>
					<meta itemprop="position" content="1" />
				</li>
							<li class="ordinal-item" itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
					<i class="sep-icon bb-icon bb-ui-icon-angle-right"></i>					<a itemprop="item" href="https://www.debugpoint.com/category/libreoffice/">
						<span itemprop="name">LibreOffice</span>
					</a>
					<meta itemprop="position" content="2" />
				</li>
							<li class="ordinal-item" itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
					<i class="sep-icon bb-icon bb-ui-icon-angle-right"></i>					<a itemprop="item" href="https://www.debugpoint.com/category/libreoffice/libreoffice-calc/">
						<span itemprop="name">LibreOffice Calc</span>
					</a>
					<meta itemprop="position" content="3" />
				</li>
							<li class="ordinal-item" itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
					<i class="sep-icon bb-icon bb-ui-icon-angle-right"></i>					<a itemprop="item" href="https://www.debugpoint.com/category/libreoffice/libreoffice-calc/calc-macros/">
						<span itemprop="name">Calc Macros</span>
					</a>
					<meta itemprop="position" content="4" />
				</li>
							<li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
					<i class="sep-icon bb-icon bb-ui-icon-angle-right"></i>					<a itemprop="item" href="https://www.debugpoint.com/debugging-libreoffice-macro-basic-using-breakpoint-and-watch/" class="last-item"><span itemprop="name">Debugging LibreOffice Basic Macro using Breakpoint and Watch</span></a>
					<meta itemprop="position" content="5">
				</li>
			
		</ol>
	</div>
</nav>		</div>

		<div class="single-main-container">
			<div class="bb-row">
				<div class="bb-col col-content">
					<div class="bb-row">
						<div class="bb-col col-site-main">
							<div class="site-main" role="main">

																	<div class="s-post-main mb-md bb-mb-el bb-card-item">

																				<header class="entry-header s-post-header bb-mb-el">

											
<div class="s-post-microdata mf-hide">
	
		<span itemprop="image" itemscope="" itemtype="https://schema.org/ImageObject">
		<!-- featured image -->
		<meta itemprop="url" content="https://www.debugpoint.com/wp-content/uploads/2014/09/debugnew1lo-768x432.jpg">
		<!-- featured image W -->
		<meta itemprop="width" content="768">
		<!-- featured image H -->
		<meta itemprop="height" content="432">
	</span>
	
	<span itemprop="publisher" itemscope="" itemtype="https://schema.org/Organization">
				<span itemprop="logo" itemscope="" itemtype="https://schema.org/ImageObject">
			<meta itemprop="url" content="https://www.debugpoint.com/wp-content/uploads/2021/12/dp-logo-2021-base2-xmas.png">
		</span>
				<meta itemprop="name" content="DebugPoint.com">
		<meta itemprop="url" content="https://www.debugpoint.com/">
	</span>
	
	<time itemprop="datePublished" datetime="2022-12-21T11:01:00+05:30">3 hours ago</time>
	<time itemprop="dateModified" datetime="2022-12-21T14:11:57+05:30">28 seconds ago</time>
	<meta itemscope="" content="" itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.debugpoint.com/debugging-libreoffice-macro-basic-using-breakpoint-and-watch/">
</div>
<div class="s-post-header-top d-table-center-sm bb-mb-el">
	
	<div class="d-table-cell text-left-sm"><p class="bb-cat-links size-lg s-post-cat-links" itemprop="keywords"><a href="https://www.debugpoint.com/category/libreoffice/libreoffice-calc/calc-macros/" rel="category tag">Calc Macros</a><span class="mf-hide">, </span><a href="https://www.debugpoint.com/category/development/" rel="category tag">Dev</a></p></div>
</div><h1 class="entry-title s-post-title bb-mb-el" itemprop="headline">Debugging LibreOffice Basic Macro using Breakpoint and Watch</h1><h2 class="entry-summary entry-sub-title s-post-summary bb-mb-el"><!--googleoff: index--><span class="bb-reading-time md"><span class="bb-clock bb-icon bb-ui-icon-clock"></span><span class="bb-text">3 min</span></span><!--googleon: index--></h2>
<hr class="bb-separator s-post-header-sep bb-mb-el" />
										</header>

																				<div class="s-post-meta-block bb-mb-el">
											<div class="post-meta-content row">
												<div class="d-table-center-sm">

													<div class="col-l d-table-cell col-md-6 col-sm-6 text-left-sm"><div class="bb-author-vcard-mini size-md" itemprop="author" itemscope="" itemtype="http://schema.org/Person"><div class="author-avatar mf-hide"><a href="https://www.debugpoint.com/author/admin1/"><img alt='Arindam' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=74&#038;d=wavatar&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=148&#038;d=wavatar&#038;r=g 2x" class='avatar avatar-74 photo lazyload' height='74' width='74' itemprop="image" decoding='async'/><noscript><img alt='Arindam' src='https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=74&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=148&#038;d=wavatar&#038;r=g 2x' class='avatar avatar-74 photo lazyload' height='74' width='74' itemprop="image" decoding='async'/></noscript></a></div><div class="author-info">
		<span class="auth-name mf-hide">
			<span class="auth-byline">by</span>
			<a class="auth-url" href="https://www.debugpoint.com/author/admin1/" itemprop="url">
				<span itemprop="name">Arindam</span>
			</a>
		</span><span class="auth-posted-on"><time class="entry-date published mf-hide" datetime="2022-12-21T11:01:00+05:30">3 hours ago</time><time class="entry-date updated" datetime="2022-12-21T14:11:57+05:30">28 seconds ago</time></span></div></div></div>
												</div>
											</div>
										</div>

										
<div itemprop="articleBody" class="s-post-content s-post-small-el bb-mb-el"><!-- dp_post_top_leader_1 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="7379524311"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<p></p>
<p><strong>A simple guide for you to learn how to debug LibreOffice basic macro using breakpoint and watch.</strong></p>



<span id="more-483"></span>



<p>While writing complex macros to automate various tasks in LibreOffice, you definitely encounter errors. Some run-time errors are self-explanatory. But some of them are very generic. To debug those, you need to carefully put breakpoints and step through the code to see where the problem is in your code. </p>



<p>Hence this tutorial. These techniques apply to all the macros written in Calc, Writer or Impress. And should be applied to OpenOffice macros as well.</p>



<h2>Debug a LibreOffice Macro written in Basic</h2>



<p>It&#8217;s easier to demonstrate this concept using an example.</p>



<h3>Define</h3>



<p>Let&#8217;s define three variables which we would use for our exercise.</p>



<pre class="wp-block-preformatted">dim i, j, cnt</pre>



<p>Define a <code>for</code> loop, which would execute from 1 to 10. Inside the loop, increment two variables as below. This is just for just this demo; however, you can put any logic you want.</p>



<pre class="wp-block-preformatted">for cnt = 1 to 10
  i = i + 1
  j = i + 1	
next cnt</pre>



<h3>Adding Breakpoint</h3>



<p>Now, we want to put two breakpoints in the statement <code>"for cnt = 1 to 10"</code> and <code>"j = i + 1"</code>. When you put a breakpoint inside your program, it runs in debug mode and holds the execution at the breakpoint.</p>



<p>To put a breakpoint in a LibreOffice Basic macro, put the cursor in the statement. And then, press <code>F9</code> or press the below button from the toolbar.</p>


<div class="wp-block-image">
<figure class="aligncenter"><img decoding="async" width="274" height="101" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_1.png" alt="Breakpoint toolbar button in LibreOffice Macro editor" class="wp-image-489 lazyload"/><noscript><img decoding="async" width="274" height="101" src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_1.png" alt="Breakpoint toolbar button in LibreOffice Macro editor" class="wp-image-489 lazyload"/></noscript><figcaption class="wp-element-caption">Breakpoint toolbar button in LibreOffice Macro editor</figcaption></figure></div>


<p>Once you do that, you will see a red circle on the left side of the statement, which means a breakpoint has been added <em>to that statement</em>. See the below image. In addition, you can add multiple breakpoints as per your needs.</p>


<div class="wp-block-image">
<figure class="aligncenter"><a href="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_2.png"><img decoding="async" width="567" height="211" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_2.png" alt="After adding breakpoints" class="wp-image-488 lazyload" data-srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_2.png 567w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_2-300x111.png 300w" sizes="(max-width: 567px) 100vw, 567px" /><noscript><img decoding="async" width="567" height="211" src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_2.png" alt="After adding breakpoints" class="wp-image-488 lazyload" srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_2.png 567w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_2-300x111.png 300w" sizes="(max-width: 567px) 100vw, 567px" /></noscript></a><figcaption class="wp-element-caption">After adding breakpoints</figcaption></figure></div>


<p><br>If you want to remove a breakpoint from a statement, press <code>F9</code> again in the statement, OR you can <code>double-click</code> the red circle.</p>



<h3>Adding Watch</h3>



<p>Now, we would add a &#8216;watch&#8217; to the variable <code>"cnt"</code>.</p>



<p>When the program executes in debug mode, the watch helps monitor a variable&#8217;s value between program steps. To add a watch on <code>"cnt" </code>variable, select the variable and press <code>F7</code> or click the glass icon in the toolbar.</p>


<div class="wp-block-image">
<figure class="aligncenter"><a href="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_3.png"><img decoding="async" width="668" height="181" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_3.png" alt="Watch button in the toolbar in LibreOffice Macro editor" class="wp-image-487 lazyload" data-srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_3.png 668w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_3-300x81.png 300w" sizes="(max-width: 668px) 100vw, 668px" /><noscript><img decoding="async" width="668" height="181" src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_3.png" alt="Watch button in the toolbar in LibreOffice Macro editor" class="wp-image-487 lazyload" srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_3.png 668w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_3-300x81.png 300w" sizes="(max-width: 668px) 100vw, 668px" /></noscript></a><figcaption class="wp-element-caption">Watch button in the toolbar in LibreOffice Macro editor</figcaption></figure></div>


<p>Once you do that, you will see the variable added to the watch list at the bottom of the editor.</p>


<div class="wp-block-image">
<figure class="aligncenter"><a href="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_4.png"><img decoding="async" width="362" height="88" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_4.png" alt="Watch section appears at the bottom of the editor" class="wp-image-486 lazyload" data-srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_4.png 362w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_4-300x72.png 300w" sizes="(max-width: 362px) 100vw, 362px" /><noscript><img decoding="async" width="362" height="88" src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_4.png" alt="Watch section appears at the bottom of the editor" class="wp-image-486 lazyload" srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_4.png 362w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_4-300x72.png 300w" sizes="(max-width: 362px) 100vw, 362px" /></noscript></a><figcaption class="wp-element-caption">Watch section appears at the bottom of the editor</figcaption></figure></div>


<h3>Execute by Step</h3>



<p>We are all set with tools.</p>



<p>Run the program by pressing <code>F5</code>. As we already added breakpoints, you would see the execution halts at the first breakpoint with a little <strong>yellow arrow</strong>.</p>


<div class="wp-block-image">
<figure class="aligncenter"><a href="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_5.png"><img decoding="async" width="223" height="67" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_5.png" alt="Execution halts at the breakpoint" class="wp-image-485 lazyload" data-srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_5.png 223w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_5-220x67.png 220w" sizes="(max-width: 223px) 100vw, 223px" /><noscript><img decoding="async" width="223" height="67" src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_5.png" alt="Execution halts at the breakpoint" class="wp-image-485 lazyload" srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_5.png 223w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_5-220x67.png 220w" sizes="(max-width: 223px) 100vw, 223px" /></noscript></a><figcaption class="wp-element-caption">Execution halts at the breakpoint</figcaption></figure></div>


<p>Now you have two options.</p>



<p>Press <code>F5</code> again to continue the execution of the program, and it will halt again at the next breakpoint.<br>Press <code>F8</code> (step execution), which would execute step by step, and you can see the &#8216;watched&#8217; variable <code>'cnt'</code> value is changing as below.</p>



<p>Lets press <code>F8</code>. You can see the yellow arrow comes to the next statement, and the compiler waits. Now the fun part, if you take a closer look at the watch window, you can see the <code>'cnt'</code>variable&#8217;s value is 1.<br></p>


<div class="wp-block-image">
<figure class="aligncenter"><img decoding="async" width="434" height="261" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_6.png" alt="Variable contents during execution" class="wp-image-484 lazyload" data-srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_6.png 434w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_6-300x180.png 300w" sizes="(max-width: 434px) 100vw, 434px" /><noscript><img decoding="async" width="434" height="261" src="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_6.png" alt="Variable contents during execution" class="wp-image-484 lazyload" srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_6.png 434w, https://www.debugpoint.com/wp-content/uploads/2014/09/LibreOffice_Debug_watch_BreakPoint_6-300x180.png 300w" sizes="(max-width: 434px) 100vw, 434px" /></noscript><figcaption class="wp-element-caption">Variable contents during execution</figcaption></figure></div>


<p><br>So this way, you can debug, add breakpoints and add watch any LibreOffice or OpenOffice macro using its editor.</p>



<p>Furthermore, you can add many watch variables as you want and debug your program for successful execution. </p>



<h2>Closing Notes</h2>



<p>Although the above example is specific to LibreOffice macros, the same concept applies to programming and debugging in general. I hope this article helps you to understand the basics of debugging, step execution and watch in programming and macros in LibreOffice.</p>



<h2>Looking for Something Else?</h2>



<p>If you are looking for something else in LibreOffice macro tutorials Or wants to learn more about it, please follow the below link for the complete Macro Tutorials Index:</p>



<div class="is-content-justification-center is-layout-flex wp-container-1 wp-block-buttons">
<div class="wp-block-button"><a class="wp-block-button__link wp-element-button" href="http://www.debugpoint.com/libreoffice-basic-macro-tutorial-index/" target="_blank" rel="noreferrer noopener">Macro Tutorial Index</a></div>
</div>
    <div style="font-style:normal;font-weight:700;" class="post-navigation-link-next wp-block-post-navigation-link has-medium-font-size"></div>
<p></p>
<!--google news and telegram link START -->
<div class="dp-gnews-link"><a href="https://news.google.com/publications/CAAqBwgKMOCfmgsw-qmyAw" target="_blank" rel="nofollow"><em>Add DebugPoint to your <strong>Google News</strong> feed. Follow us:</em>
<img style="box-shadow: none;" src="data:image/png;base64,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"></img>
</a></div>
<div class="dp-telegram-link"><a href="https://t.me/debugpoint" target="_blank" rel="nofollow"><em>Join our <strong>Telegram Channel</strong> and stay informed on the move.</strong></em>
<img style="box-shadow: none;" src="data:image/png;base64,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"></img>
</a></div>
<!--google news and telegram link END -->
<p></p>	
<!-- post_bottom_banner_resp -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="8619046127"
     data-ad-format="auto"></ins>
<script type="rocketlazyloadscript">
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
	<p></p>

<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="8197723605"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<nav class="bb-next-prev-pagination s-post-next-prev-pg mb-md bb-mb-el pg-md"><h2 class="screen-reader-text">Post Pagination</h2><ul class="pg-list"><li class="pg-item bb-disabled page-nav prev-page"></li><li class="pg-item page-nav next-page"><a class="next-page-link page-link" href="https://www.debugpoint.com/linux-mint/" rel="next"><i class="bb-icon bb-ui-icon-chevron-right"></i><span class="text big-text">Next Post</span><span class="text small-text">Next</span></a></li></ul></nav>
<hr class="bb-separator bb-mb-el" /><div class="bb-tags mb-md bb-mb-el" itemprop="keywords"><a href="https://www.debugpoint.com/tag/libreoffice-macro/" rel="tag">libreoffice macro</a></div>
									</div>
									
									<section class="bb-author-vcard s-post-small-el mb-md bb-mb-el">
				<div class="author" itemscope="" itemtype="http://schema.org/Person">
					<header>
						<div class="avatar auth-avatar circle-frame">
							<a href="https://www.debugpoint.com/author/admin1/"><img alt='Arindam' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=186&#038;d=wavatar&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=372&#038;d=wavatar&#038;r=g 2x" class='avatar avatar-186 photo lazyload' height='186' width='186' itemprop="image" decoding='async'/><noscript><img alt='Arindam' src='https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=186&#038;d=wavatar&#038;r=g' srcset='https://secure.gravatar.com/avatar/817f1324a0121daed334e248723abb17?s=372&#038;d=wavatar&#038;r=g 2x' class='avatar avatar-186 photo lazyload' height='186' width='186' itemprop="image" decoding='async'/></noscript></a>
						</div>
						
						<div class="header-info">
							<h3 class="auth-name">
								<span class="auth-byline">Posted by</span>
								<a class="auth-url" itemprop="url" href="https://www.debugpoint.com/author/admin1/">
									<span itemprop="name">Arindam</span>
								</a>
								
							</h3>
							
						</div>
					</header>
			
					<div class="author-info">
						<div class="auth-desc" itemprop="description">Creator of debugpoint.com. All time Linux user and open-source supporter. Connect with me via <a href="https://t.me/arindamgiri">Telegram</a>, <a href="https://twitter.com/_arindam">Twitter</a>, <a href="https://www.linkedin.com/in/arindam-giri/">LinkedIn</a>, or send us an <a href="mailto:contact@debugpoint.com">email</a>.</div>
						
					</div>
				</div>
			</section><nav class="bb-post-nav s-post-small-el bb-mb-el bb-no-play">
	<div class="row">
		<ul>
							<li class="next-page col-xs-12 col-md-6 col-lg-6">
					<span class="meta-nav">Next Post</span>

					<div class="pg-item bb-card-item">

													<div class="pg-thumb-col pg-col">
								<a class="pg-thumb" href="https://www.debugpoint.com/linux-mint/">
									<div class="bb-media-placeholder" style="padding-bottom:100%;"><img width="150" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/06/linuxmint-logo-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Linux Mint: The King of all distros" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/06/linuxmint-logo-150x150.jpg 150w, https://www.debugpoint.com/wp-content/uploads/2022/06/linuxmint-logo-96x96.jpg 96w" sizes="(max-width: 150px) 100vw, 150px" /></div>								</a>
							</div>
						
						<div class="pg-content-col pg-col">
							<h6 class="post-title">
								<a href="https://www.debugpoint.com/linux-mint/">Linux Mint: The Beginner-Friendly Linux Operating System for Everyone</a>
							</h6>
							<div class="bb-author-vcard-mini post-author-vcard"><div class="author-info">
		<span class="auth-name">
			<span class="auth-byline">by</span>
			<a class="auth-url" href="https://www.debugpoint.com/author/admin1/">
				<span>Arindam</span>
			</a>
		</span></div></div>						</div>
					</div>
				</li>
			
		</ul>
	</div>
</nav>		<aside class="bb-other-posts bb-posts-more-from bb-post-collection hfeed mb-lg bb-mb-el hfeed post-list list list big-item bb-thumbnail-stretched">

							<h3 class="title">More From: <a href="https://www.debugpoint.com/category/libreoffice/libreoffice-calc/calc-macros/">Calc Macros</a></h3>
			
						<ul class="post-items">
				
	<li class="post-item post-item-list">
		<article class="post bb-post bb-card-item post-449 type-post status-publish format-standard has-post-thumbnail category-calc-macros category-development tag-libreoffice-macro">

			<!-- thumbnail -->
			<div class="post-thumbnail">
				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">9.7k</span></span></div>					<a href="https://www.debugpoint.com/writing-a-macro-in-libreoffice-calc-getting-started/"
					   title="Writing a Macro in LibreOffice Calc: Getting Started"  >
						<div class="bb-media-placeholder" style="padding-bottom:50%;"><img width="360" height="180" src="https://www.debugpoint.com/wp-content/uploads/2014/09/new-macro-head1-360x180.jpg" class="attachment-boombox_image360x180 size-boombox_image360x180 wp-post-image" alt="" decoding="async" loading="lazy" /></div>					</a>

								</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<div class="bb-post-terms"><div class="post-meta bb-post-meta"><a href="https://www.debugpoint.com/writing-a-macro-in-libreoffice-calc-getting-started/#comments" class="post-meta-item post-comments"><i class="bb-icon bb-ui-icon-comment"></i><span class="count">21</span></a></div></div><h2 class="entry-title"><a href="https://www.debugpoint.com/writing-a-macro-in-libreoffice-calc-getting-started/" rel="bookmark"  >Writing a Macro in LibreOffice Calc: Getting Started</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>


	<li class="post-item post-item-list">
		<article class="post bb-post bb-card-item post-705 type-post status-publish format-standard has-post-thumbnail category-calc-macros tag-libreoffice tag-macro">

			<!-- thumbnail -->
			<div class="post-thumbnail">
				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">6.6k</span></span></div>					<a href="https://www.debugpoint.com/string-processing-in-libreoffice-calc-macro-with-examples/"
					   title="String Processing in LibreOffice Calc Macro with Examples"  >
						<div class="bb-media-placeholder" style="padding-bottom:50%;"><img width="360" height="180" src="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-360x180.jpg" class="attachment-boombox_image360x180 size-boombox_image360x180 wp-post-image" alt="" decoding="async" loading="lazy" /></div>					</a>

								</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<div class="bb-post-terms"><div class="post-meta bb-post-meta"><a href="https://www.debugpoint.com/string-processing-in-libreoffice-calc-macro-with-examples/#comments" class="post-meta-item post-comments"><i class="bb-icon bb-ui-icon-comment"></i><span class="count">14</span></a></div></div><h2 class="entry-title"><a href="https://www.debugpoint.com/string-processing-in-libreoffice-calc-macro-with-examples/" rel="bookmark"  >String Processing in LibreOffice Calc Macro with Examples</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>


	<li class="post-item post-item-list">
		<article class="post bb-post bb-card-item post-1441 type-post status-publish format-standard has-post-thumbnail category-calc-macros category-libreoffice-calc tag-getcurrentselection tag-macro tag-unoexportdirecttopdf">

			<!-- thumbnail -->
			<div class="post-thumbnail">
				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">1.9k</span></span></div>					<a href="https://www.debugpoint.com/export-or-save-as-pdf-a-specific-range-in-libreoffice-calc-sheets-using-macro/"
					   title="Export or Save As PDF A Specific Range in LibreOffice Calc Sheets using Macro"  >
						<div class="bb-media-placeholder" style="padding-bottom:50%;"><img width="360" height="180" src="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-360x180.jpg" class="attachment-boombox_image360x180 size-boombox_image360x180 wp-post-image" alt="" decoding="async" loading="lazy" /></div>					</a>

								</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<div class="bb-post-terms"><div class="post-meta bb-post-meta"><a href="https://www.debugpoint.com/export-or-save-as-pdf-a-specific-range-in-libreoffice-calc-sheets-using-macro/#comments" class="post-meta-item post-comments"><i class="bb-icon bb-ui-icon-comment"></i><span class="count">18</span></a></div></div><h2 class="entry-title"><a href="https://www.debugpoint.com/export-or-save-as-pdf-a-specific-range-in-libreoffice-calc-sheets-using-macro/" rel="bookmark"  >Export or Save As PDF A Specific Range in LibreOffice Calc Sheets using Macro</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>

			</ul>
					</aside>

		    <aside class="bb-other-posts bb-posts-dont-miss bb-post-collection hfeed mb-xs bb-mb-el hfeed post-grid bb-thumbnail-stretched col-3">

                    <h2 class="title">DON&#039;T MISS</h2>
        
                <ul class="post-items">
            
	<li class="post-item post-item-grid">
		<article class="post bb-post bb-card-item post-10081 type-post status-publish format-standard has-post-thumbnail category-distributions tag-linux-mint">

			<!-- thumbnail -->
			<div class="post-thumbnail">

				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">2.8k</span></span></div>
					<a href="https://www.debugpoint.com/linux-mint/"
					   title="Linux Mint: The Beginner-Friendly Linux Operating System for Everyone"  >
						<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="360" height="270" src="https://www.debugpoint.com/wp-content/uploads/2022/06/linuxmint-logo-360x270.jpg" class="attachment-boombox_image360x270 size-boombox_image360x270 wp-post-image" alt="Linux Mint: The King of all distros" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/06/linuxmint-logo-360x270.jpg 360w, https://www.debugpoint.com/wp-content/uploads/2022/06/linuxmint-logo-200x150.jpg 200w" sizes="(max-width: 700px) 100vw, (max-width: 900px) 400px, (max-width: 1200px) 300px, 360px" /></div>					</a>

					
				
			</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<div class="bb-post-terms"><div class="post-meta bb-post-meta"><a href="https://www.debugpoint.com/linux-mint/#comments" class="post-meta-item post-comments"><i class="bb-icon bb-ui-icon-comment"></i><span class="count">2</span></a></div></div><h2 class="entry-title"><a href="https://www.debugpoint.com/linux-mint/" rel="bookmark"  >Linux Mint: The Beginner-Friendly Linux Operating System for Everyone</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>


	<li class="post-item post-item-grid">
		<article class="post bb-post bb-card-item post-10556 type-post status-publish format-standard has-post-thumbnail category-distributions category-tutorials tag-linux-mint-20-3 tag-linux-mint-21">

			<!-- thumbnail -->
			<div class="post-thumbnail">

				<div class="post-meta bb-post-meta post-meta-bg"><span class="post-meta-item post-views"><span class="bb-icon bb-ui-icon-eye-1"></span><span class="count">5.4k</span></span></div>
					<a href="https://www.debugpoint.com/upgrade-linux-mint-21-from-20-3/"
					   title="Upgrade to Linux Mint 21 and 21.1 from Mint 20.3 [Complete Guide]"  >
						<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="360" height="270" src="https://www.debugpoint.com/wp-content/uploads/2022/08/mint21up-360x270.jpg" class="attachment-boombox_image360x270 size-boombox_image360x270 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/08/mint21up-360x270.jpg 360w, https://www.debugpoint.com/wp-content/uploads/2022/08/mint21up-200x150.jpg 200w" sizes="(max-width: 700px) 100vw, (max-width: 900px) 400px, (max-width: 1200px) 300px, 360px" /></div>					</a>

					
				
			</div>
			<!-- thumbnail -->

			<div class="content">
				<!-- entry-header -->
				<header class="entry-header">
					<div class="bb-post-terms"><div class="post-meta bb-post-meta"><a href="https://www.debugpoint.com/upgrade-linux-mint-21-from-20-3/#comments" class="post-meta-item post-comments"><i class="bb-icon bb-ui-icon-comment"></i><span class="count">3</span></a></div></div><h2 class="entry-title"><a href="https://www.debugpoint.com/upgrade-linux-mint-21-from-20-3/" rel="bookmark"  >Upgrade to Linux Mint 21 and 21.1 from Mint 20.3 [Complete Guide]</a></h2>				</header>
				<!-- entry-header -->
			</div>

		</article>
	</li>

        </ul>
        
    </aside>
    															</div>
						</div>

						
<div class="bb-col col-sidebar-secondary" xmlns="http://www.w3.org/1999/html">
	<aside id="secondary-small" class="sidebar-secondary widget-area">
		<section  class="sticky-sidebar"></section><section id="custom_html-49" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- ad2_small_top_right -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="1716718128"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section><section id="custom_html-51" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- story1 exp-->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="1400854534"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script type="rocketlazyloadscript">
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section>	</aside>
</div>					</div>
				</div>

				<div class="bb-col col-sidebar">
	<aside id="secondary" class="sidebar widget-area">
		<section id="custom_html-36" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://t.me/debugpoint"><img width="400" height="120" alt="Join our Telegram channel and stay informed on the move." src="https://www.debugpoint.com/wp-content/uploads/2020/07/telegramjoin1.png" style="height:120px; width:400px;"></a></div></section>
		<section id="recent-posts-9" class="widget widget_recent_entries">
		<h4 class="widget-title">Recent Articles</h4>
		<ul>
											<li>
					<a href="https://www.debugpoint.com/debugging-libreoffice-macro-basic-using-breakpoint-and-watch/" aria-current="page">Debugging LibreOffice Basic Macro using Breakpoint and Watch</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/linux-mint/">Linux Mint: The Beginner-Friendly Linux Operating System for Everyone</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/upgrade-linux-mint-21-from-20-3/">Upgrade to Linux Mint 21 and 21.1 from Mint 20.3 [Complete Guide]</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/mint-upgrade-tool/">Linux Mint Upgrade Tool: Usage Guide</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/endeavouros-review/">EndeavourOS: Your Search for Perfect Arch Distro Ends Here</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/flatpak-commands/">Become A Pro Flatpak User By Learning These Commands</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/find-ubuntu-version/">How to Find Out Ubuntu Version: 6 Methods</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/writing-a-macro-in-libreoffice-calc-getting-started/">Writing a Macro in LibreOffice Calc: Getting Started</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/xfce-4-18-xubuntu-22-04/">How to Get Xfce 4.18 in Xubuntu 22.04 and 22.10</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/fedora-media-writer/">Fedora Media Writer: World-Class LIVE USB Creator [Tutorial]</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/5-best-python-ide-code-editor/">6 Best Python IDE(s) and Code Editor(s)</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/download-firefox/">Download Firefox Browser: All Version Links and Details</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/how-enable-volume-power-control-amazon-fire-tv-stick/">How to Enable Volume and Power Control in Amazon Fire TV Stick</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/xerolinux-review/">XeroLinux Review: Stunning Linux Distribution with Arch and KDE Plasma</a>
									</li>
											<li>
					<a href="https://www.debugpoint.com/libreoffice-7-5/">LibreOffice 7.5: Top New Features &#038; Release Info</a>
									</li>
					</ul>

		</section><section id="rss-5" class="widget widget_rss"><h4 class="widget-title"><a class="rsswidget rss-widget-feed" href="https://debugpointnews.com/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.debugpoint.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget rss-widget-title" href="https://debugpointnews.com/">Latest from: DebugPoint News</a></h4><ul><li><a class='rsswidget' href='https://debugpointnews.com/linux-mint-21-1-release/'>Linux Mint 21.1 “Vera” is Officially Released. This is What’s New</a></li><li><a class='rsswidget' href='https://debugpointnews.com/weekly-newsletter-22-15/'>DebugPoint Weekly Newsletter #22.15: Plasma Fractional Scaling, FreeBSD 12.4 + More</a></li><li><a class='rsswidget' href='https://debugpointnews.com/gtk-file-chooser-thumbnail/'>After 18 Years, Gtk Native File Chooser Gets Thumbnail View</a></li><li><a class='rsswidget' href='https://debugpointnews.com/firefox-108/'>Firefox 108 unlocks the power of music on the web with new WebMIDI API support</a></li></ul></section><section  class="sticky-sidebar"></section><section id="custom_html-38" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- dp_sidebar_resp_new -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1235852655833346"
     data-ad-slot="2725480046"
     data-ad-format="auto"></ins>
<script type="rocketlazyloadscript">
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section><section id="same-category-posts-10" class="widget same-category-posts"><h4 class="widget-title"><a href="https://www.debugpoint.com/tag/libreoffice-macro/">Related Articles</a></h4><ul>
<li class="same-category-post-item "><a class="post-title" href="https://www.debugpoint.com/writing-a-macro-in-libreoffice-calc-getting-started/" rel="bookmark" title="Permanent Link to Writing a Macro in LibreOffice Calc: Getting Started">Writing a Macro in LibreOffice Calc: Getting Started</a></li><li class="same-category-post-item "><a class="post-title" href="https://www.debugpoint.com/change-impress-layout-runtime-basic-macro-tutorial/" rel="bookmark" title="Permanent Link to Change Impress Layout at Runtime Using Basic Macro">Change Impress Layout at Runtime Using Basic Macro</a></li><li class="same-category-post-item "><a class="post-title" href="https://www.debugpoint.com/how-to-add-push-button-on-calc-sheet-and-use-it/" rel="bookmark" title="Permanent Link to How to Add Push Button on Calc Sheet and Use It">How to Add Push Button on Calc Sheet and Use It</a></li><li class="same-category-post-item "><a class="post-title" href="https://www.debugpoint.com/writing-macro-in-libreoffice-impress-getting-started/" rel="bookmark" title="Permanent Link to Writing Macro in LibreOffice Impress &amp;#8211; Getting Started">Writing Macro in LibreOffice Impress &#8211; Getting Started</a></li></ul>
</section>
	</aside>
</div>
			</div>
		</div>
	</article>
	
</div>

			<!--Div for sticky elements -->
			<div id="sticky-border"></div>
			</main>

							<footer id="footer" class="footer ">
					
<div class="footer-top">
	
	<div class="container">

				<div class="bb-featured-strip featured-carousel big-item outside-title mb-md">
		<ul>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/2-ways-fix-laptop-brightness-problem-ubuntu-linux/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2016/10/brightness-head-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2016/10/brightness-head-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2016/10/brightness-head-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">4 Ways to Fix the Laptop Brightness Problem...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/2-ways-fix-laptop-brightness-problem-ubuntu-linux/">
							4 Ways to Fix the Laptop Brightness Problem...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/best-linux-distributions-2022/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/05/bestlinux1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/05/bestlinux1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2022/05/bestlinux1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Top 10 Best Linux Distributions in 2022 For...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/best-linux-distributions-2022/">
							Top 10 Best Linux Distributions in 2022 For...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/how-enable-volume-power-control-amazon-fire-tv-stick/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2020/03/amazon-fire-2-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2020/03/amazon-fire-2-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2020/03/amazon-fire-2-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Enable Volume and Power Control in...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/how-enable-volume-power-control-amazon-fire-tv-stick/">
							How to Enable Volume and Power Control in...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/windows-11-inspiration-linux-kde-plasma/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/06/win11plasma-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Windows 11 Look Inspired by KDE Plasma and...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/windows-11-inspiration-linux-kde-plasma/">
							Windows 11 Look Inspired by KDE Plasma and...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/ubuntu-should-choose-kde-plasma/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/01/ubuntukdegnome-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Should Ubuntu Adopt KDE Plasma as Default Desktop?...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/ubuntu-should-choose-kde-plasma/">
							Should Ubuntu Adopt KDE Plasma as Default Desktop?...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/top-linux-distributions-kde-plasma/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2021/12/kde-top-10-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/12/kde-top-10-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2021/12/kde-top-10-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Top 10 Linux Distributions for KDE Plasma [Compared]</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/top-linux-distributions-kde-plasma/">
							Top 10 Linux Distributions for KDE Plasma [Compared]						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/writing-a-macro-in-libreoffice-calc-getting-started/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2014/09/new-macro-head1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2014/09/new-macro-head1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2014/09/new-macro-head1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Writing a Macro in LibreOffice Calc: Getting Started</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/writing-a-macro-in-libreoffice-calc-getting-started/">
							Writing a Macro in LibreOffice Calc: Getting Started						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/beautiful-linux-distributions-2022/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/03/beauty-1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/03/beauty-1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2022/03/beauty-1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Top 10 Most Beautiful Linux Distributions [Featured]</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/beautiful-linux-distributions-2022/">
							Top 10 Most Beautiful Linux Distributions [Featured]						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/remove-snap-ubuntu/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/04/snapstop-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/04/snapstop-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2022/04/snapstop-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Remove Snap Packages in Ubuntu Linux</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/remove-snap-ubuntu/">
							How to Remove Snap Packages in Ubuntu Linux						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/export-or-save-as-pdf-a-specific-range-in-libreoffice-calc-sheets-using-macro/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Export or Save As PDF A Specific Range...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/export-or-save-as-pdf-a-specific-range-in-libreoffice-calc-sheets-using-macro/">
							Export or Save As PDF A Specific Range...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/upgrade-pop-os-21-04-from-20-10/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/07/pop2104upgradehead-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Upgrade to Pop OS 21.04 from...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/upgrade-pop-os-21-04-from-20-10/">
							How to Upgrade to Pop OS 21.04 from...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/working-with-dialog-controls-in-libreoffice-calc-using-macro-part-1/">
							<div class="bb-media-placeholder" style="padding-bottom:51%;"><img width="200" height="102" src="https://www.debugpoint.com/wp-content/uploads/2015/01/LO-3d-Header.png" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2015/01/LO-3d-Header.png 487w, https://www.debugpoint.com/wp-content/uploads/2015/01/LO-3d-Header-300x153.png 300w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Working with Dialog Controls in LibreOffice Calc using...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/working-with-dialog-controls-in-libreoffice-calc-using-macro-part-1/">
							Working with Dialog Controls in LibreOffice Calc using...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/failed-to-start-lightdm/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/03/failedlightdm-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Fix &#8211; Failed to Start Light...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/failed-to-start-lightdm/">
							How to Fix &#8211; Failed to Start Light...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/libreoffice-like-microsoft-office/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2021/06/lomsofhead-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Make LibreOffice Look Like Microsoft Office</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/libreoffice-like-microsoft-office/">
							How to Make LibreOffice Look Like Microsoft Office						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/end-of-elementary-os/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2022/04/elementaryend-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2022/04/elementaryend-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2022/04/elementaryend-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">Is this the End of the road for...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/end-of-elementary-os/">
							Is this the End of the road for...						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/kde-plasma-overview-like-gnome/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2021/11/newoverhead1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="New Effect in Plasma" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2021/11/newoverhead1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2021/11/newoverhead1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">KDE Plasma Introduces GNOME-like Overview. Is it Good?</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/kde-plasma-overview-like-gnome/">
							KDE Plasma Introduces GNOME-like Overview. Is it Good?						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/string-processing-in-libreoffice-calc-macro-with-examples/">
							<div class="bb-media-placeholder" style="padding-bottom:75%;"><img width="200" height="150" src="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-200x150.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-200x150.jpg 200w, https://www.debugpoint.com/wp-content/uploads/2015/08/macro-head-1-360x270.jpg 360w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">String Processing in LibreOffice Calc Macro with Examples</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/string-processing-in-libreoffice-calc-macro-with-examples/">
							String Processing in LibreOffice Calc Macro with Examples						</a>
					</h3>
				</li>
							<li class="item ">
					<figure class="media">
						<a href="https://www.debugpoint.com/xfce-arch-linux-install-4-16/">
							<div class="bb-media-placeholder" style="padding-bottom:56.5%;"><img width="200" height="113" src="https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead.jpg" class="attachment-boombox_image200x150 size-boombox_image200x150 wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead.jpg 1200w, https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead-300x169.jpg 300w, https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead-1024x576.jpg 1024w, https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead-768x432.jpg 768w, https://www.debugpoint.com/wp-content/uploads/2020/12/xfce416archhead-900x515.jpg 900w" sizes="(max-width: 200px) 100vw, 200px" /></div>							<span class="title-inside">How to Install Xfce Desktop in Arch Linux...</span>
						</a>
					</figure>
					<h3 class="title">
						<a href="https://www.debugpoint.com/xfce-arch-linux-install-4-16/">
							How to Install Xfce Desktop in Arch Linux...						</a>
					</h3>
				</li>
					</ul>
	</div>
	
					<div class="row">
				<div class="col-md-4 mb-md">
					<section id="text-77" class="widget widget_text">			<div class="textwidget"><p><a href="https://www.debugpoint.com">DebugPoint.com</a> is a portal covering Technology, Software News and stuff that matters. Heavily slant towards Linux and Open Source.</p>
<p>All applications are registered trademarks of their respective owners. Icons and Logos are used for information purposes, and credit is provided at the end of corresponding articles.</p>
<p>This site serves Ads by a third party that uses cookies and serves ads based on user browsing patterns.</p>
<p>Ideas and opinions expressed here are owned by the author and don&#8217;t necessarily reflect those of other people or organizations.</p>
<p>Linux is a registered trademark of Linus Torvalds.</p>
</div>
		</section>				</div>
				<div class="col-md-4 mb-md">
					<section id="nav_menu-3" class="widget widget_nav_menu"><h4 class="widget-title">Stay in touch</h4><div class="menu-social_links-container"><ul id="menu-social_links-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-832"><a href="http://www.debugpoint.com/feed">RSS</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10578"><a href="https://t.me/debugpoint">Telegram Channel</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10577"><a href="https://news.google.com/publications/CAAqBwgKMOCfmgsw-qmyAw">Google News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-831"><a href="https://twitter.com/DebugPoint">Twitter</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-830"><a href="https://floss.social/@debugpoint">Mastodon</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-833"><a href="https://www.youtube.com/c/Debugpoint">YouTube</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-829"><a href="http://www.facebook.com/DebugPoint">Facebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10579"><a href="https://www.reddit.com/r/debugpoint/">r/debugpoint</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10580"><a href="http://contact@debugpoint.com">Email</a></li>
</ul></div></section>				</div>
				<div class="col-md-4 mb-md">
					<section id="blog_subscription-5" class="widget widget_blog_subscription jetpack_subscription_widget"><h4 class="widget-title">Subscribe to us via Email</h4>
			<div class="wp-block-jetpack-subscriptions__container">
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-5">
									<div id="subscribe-text"><p>Enter your email address to subscribe to debugpoint.com and receive notifications of new posts by email.</p>
</div>
																			<p id="subscribe-email">
						<label id="jetpack-subscribe-label"
							class="screen-reader-text"
							for="subscribe-field-blog_subscription-5">
							Email Address						</label>
						<input type="email" name="email" required="required"
																					value=""
							id="subscribe-field-blog_subscription-5"
							placeholder="Email Address"
						/>
					</p>

					<p id="subscribe-submit"
											>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="source" value="https://www.debugpoint.com/debugging-libreoffice-macro-basic-using-breakpoint-and-watch/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="subscribe-blog-blog_subscription-5"/>
												<button type="submit"
															class="wp-block-button__link"
																					name="jetpack_subscriptions_widget"
						>
							Subscribe						</button>
					</p>
							</form>
						</div>
			
</section><section id="custom_html-47" class="widget_text widget widget_custom_html"><h4 class="widget-title">Other Projects</h4><div class="textwidget custom-html-widget"><ul>
	<li><a href="https://debugpointnews.com">debugpointnews.com</a></li>
</ul></div></section>				</div>
			</div>
			</div>
</div>
<div class="footer-bottom">
	
	<div class="container">

					<div class="footer-nav">
				<nav>
					<ul id="menu-about_menu" class=""><li id="menu-item-3701" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3701"><a href="https://www.debugpoint.com/about/">About</a></li>
<li id="menu-item-3702" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3702"><a href="https://www.debugpoint.com/content-policy/">Content Policy</a></li>
<li id="menu-item-3703" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3703"><a href="https://www.debugpoint.com/contact-debugpoint/">Contact</a></li>
</ul>				</nav>
			</div>
		
		
		<div class="copy-right">&copy;
			2022 DebugPoint.com All Rights Reserved | Created with ❤ in India 🇮🇳.		</div>

	</div>
</div>				</footer>
			
        <span id="go-top" class="go-top"><i class="bb-icon bb-ui-icon-arrow-up"></i></span>
		</div>

		<div class="light-modal-bg"></div>
<!-- Modal content -->
<div id="sign-in" class="light-modal sign-in authentication">
	<a href="#" class="modal-close"><i class="bb-icon bb-ui-icon-close"></i></a>
	<div class="modal-body wrapper">
		<div class="content-wrapper">
			<header class="content-header">
									<h3 class="title">log in</h3>
				
							</header>
			<div class="content-body">
									<div class="clearfix"></div>
				
				<p class="status-msg bb-txt-msg"></p>

				<form id="boombox-login" class="ajax-auth" action="login" method="post">
					<input type="hidden" id="security" name="security" value="d48ce32df5" /><input type="hidden" name="_wp_http_referer" value="/debugging-libreoffice-macro-basic-using-breakpoint-and-watch/" />					<div class="input-field">
						<input type="text" name="useremail" class="required" placeholder="Your username or e-mail">
					</div>
					<div class="input-field">
						<input type="password" name="password" class="required" placeholder="Your password">
					</div>

					
					
													<div class="input-field captcha-container loading">
								<div class="form-captcha">
									<img src="" alt="Captcha!" class="captcha">
									<a href="#refresh-captcha" class="auth-refresh-captcha refresh-captcha"></a>
								</div>
								<input type="text" class="required bb-captcha-field" name="captcha-code"
									   placeholder="Enter captcha">
							</div>
											
					<div class="input-field">
						<button class="bb-btn" type="submit">log in</button>
					</div>
					<div class="input-field row-forgot-password">
						<a class="forgot-password-link js-authentication" href="#forgot-password">Forgot password?</a>
					</div>
				</form>
							</div>
					</div>
	</div>
</div>

<!-- Modal content -->
<div id="forgot-password" class="light-modal authentication">
	<a href="#" class="modal-close"><i class="bb-icon bb-ui-icon-close"></i></a>
	<div class="modal-body wrapper">
		<div class="content-wrapper">
			<header class="content-header">
									<h3 class="title">forgot password</h3>
				
							</header>
			<div class="content-body">
				<p class="status-msg bb-txt-msg"></p>
				<form id="boombox_forgot_password" class="ajax-auth" action="forgot_password" method="post">
					<input type="hidden" id="forgotsecurity" name="forgotsecurity" value="ca055a7963" /><input type="hidden" name="_wp_http_referer" value="/debugging-libreoffice-macro-basic-using-breakpoint-and-watch/" />					<div class="input-field">
						<input type="text" name="userlogin" class="required"
						       placeholder="Your username or e-mail">
					</div>
					<div class="input-field">
						<button class="bb-btn" type="submit">reset</button>
					</div>
				</form>
			</div>
			<div class="content-footer">
				<div class="bottom">
					<div class="text">Back to </div>
					<a class="bb-btn bb-btn-default js-authentication"
					   href="#sign-in">log in</a>
				</div>
			</div>
		</div>
	</div>
</div>


<style id='core-block-supports-inline-css' type='text/css'>
.wp-block-buttons.wp-container-1{justify-content:center;}
</style>
<script type='text/javascript' src='https://www.debugpoint.com/wp-content/plugins/sg-cachepress/assets/js/lazysizes.min.js?ver=7.2.9' id='siteground-optimizer-lazy-sizes-js-js' defer></script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/www.debugpoint.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' id='boombox-scripts-min-js-extra'>
/* <![CDATA[ */
var boombox_global_vars = {"boombox_gif_event":"click","single_post_animated_hyena_gifs_excluded_js_selectors":[],"videoOptions":{"playerControls":"mute","autoPlay":"scroll","sound":"muted","clickEvent":"mute_unmute","loop":1}};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-content/themes/boombox/js/scripts.min.js?ver=2.8.4' id='boombox-scripts-min-js' defer></script>
<script type='text/javascript' id='boombox-ajax-js-extra'>
/* <![CDATA[ */
var boombox_ajax_params = {"ajax_url":"https:\/\/www.debugpoint.com\/wp-admin\/admin-ajax.php","track_view":"1","track_view_request_cache":"1"};
/* ]]> */
</script>
<script type="rocketlazyloadscript" data-rocket-type='text/javascript' src='https://www.debugpoint.com/wp-content/themes/boombox/includes/rate-and-vote-restrictions/js/ajax.min.js?ver=2.8.4' id='boombox-ajax-js' defer></script>
	<script src='https://stats.wp.com/e-202251.js' defer></script>
	<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'178518717',post:'483',tz:'5.5',srv:'www.debugpoint.com',j:'1:11.6'} ]);
		_stq.push([ 'clickTrackerInit', '178518717', '483' ]);
	</script>	</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1671612145 -->